Patches for ConVirt 1.1

 
 
 

Contents

Patches for ConVirt 1.1

This page outlines procedure to patch a ConVirt installation and has list of released patches for version 1.1

General procedure

Here is the procedure to apply patches. Please use this unless different instructions are given for a given patch.

  • log in to the machine where ConVirt is installed.
  • Download the patch file in ConVirt installation (usually /usr/share/convirt)
  • patch -p0 < patch_file_name
  • Restart ConVirt.

For convenience a cumulative patches is provided that bundles a bunch of patches. Please apply patches from either cumulative set OR individual ones, not both.


Cumulative Patches

This section is useful for users who just installed ConVirt 1.1 and want to apply all patches.

ConVirt 1.1 Patch Bundles

Patch Bundle # 1
Description : Cumulative patch bundle - 9-oct-09
Severity : Recommended
Comments :
Patch file(s) : patch_file


convirture-tool 1.1 Patch Bundles

Patch Bundle # 1
Description : Cumulative Patch bundle for convirt tools 2-oct-09
Severity : Recommended
Comments : Note this patch needs to be applied in the directory where you downloaded the convirt-tool
Patch file(s) : patch_file





Individual Patches

These section is useful, if you have already applied few patches and want to apply new patches. If you have a new ConVirt installation, then it is recommended to use the Cumulative patch section.

ConVirt 1.1 Patches

Patch # 1
Description : Uninitialized variable in ManagedNode.py
Severity : CRITICAL
Comments :
Patch file(s) : patch_file



Patch # 2
Description : KVM : kernel/ramdisk and append param not handled correctly
Severity : MINOR
Comments : Required if you want to use kernel/ramdisk and append params.
Patch file(s) : patch_file



Patch # 3
Description : KVM : Error migrating test : invalid literal for int() with base 10. More details
Severity : CRITICAL
Comments : Required if you want to use KVM using recent/latest versions. e.g. kvm-devel-88
Requires : Patch #2 be applied before.
Patch file(s) : patch_file



Patch # 4
Description : Few issues found while adding RHEL 5.4 support.

  1. Error in case there are no bridge interfaces.
  2. Path adjustment for RHEL 5.4 KVM binary.
  3. A bug in ui_utils for displaying server information.

Severity : CRITICAL
Comments : Required for RHEL5.4 KVM platform, recommended for others
Requires : Patch #3 be applied before.
Patch file(s) : patch_file



Patch # 5
Description : Missing XenClient module, import error.
Severity : CRITICAL
Comments : Required for Ubuntu platform, recommended for others
Patch file(s) : patch_file



Patch # 6
Description : Missing leading quote in KVM cmdline.
Severity : CRITICAL
Comments : Required for KVM platform, recommended for others
Requires : Patch #4 be applied before.
Patch file(s) : patch_file





convirture-tool 1.1 Patches

Patch # 1
Description : Xen : convirturetools modifies xend entries and removes xenbr0 More details
Severity : CRITICAL
Comments : For Xen platform it is highly recommended. Note this patch needs to be applied in the directory where you downloaded the convirt-tool
Patch file(s) : patch_file



Patch # 2
Description : Fixes bridge setup for KVM on Fedora/RHEL/CentOS platform. And opens up firewall for migration.
Severity : CRITICAL
Comments : Assumes patch #1 is applied. Note this patch needs to be applied in the directory where you downloaded the convirt-tool
Patch file(s) : patch_file

 
Vous avez d’autres questions ? Envoyer une demande

Commentaires

 
Adding comment, please wait....

Provide Feedback on Article:

Subject:
Comments:*