Radia Support

Deborah Cowin
MS June 2020 patches

After the June 2020 patches were installed on our Radia 10 site server (Windows Server 2016), we cannot assign patchmgr or software zservices in the console.  Has anyone experienced any issues in the console assigning active directory policy after June 2020 updates installed on site server?

Debby Cowin

1 0
Nancy Lever

The AUDIT.FILE.ACTION FLAGS includes 3 flags at the end.  the first is to detect the file and send it, the second to delete the file and the third is for a CUSTOM action.  The only explanation provided is "Execute the method indicated in the CUSTOM attribute"


I'd like to take advantage of this to include a rename of the file instead of simply report and/or delete.  Has anyone used it?


3 0
Libor Janda
Radia 10 Patch manager error 709

Hello all,

for last several weeks I've got strange error where checking, installing and repairing PATCH ZSERVICEs in my demo environment. I've got same error for MS, Java and Adobe patches. Have you any idea how to repair this? Or what to delete, clear, refresh, redeploy or reacquire to make to work correctly? I waited for November MS patches but it didn't help.

In connect log there for every of that services something like this:

20181123 13:29:48 Info: name {Windows Malicious Software Removal Tool x64 - November 2018 (KB890830)} vendorID 73122b1f-6bfc-4601-b77e-89fccb891423 title {Windows Malicious Software Removal Tool x64 - November 2018 (KB890830)} url http://download.windowsupdate.com/c/msdownload/update/software/uprl/2018/11/windows-kb890830-x64-v5.66_324d7f131dd4bd5ede96c9526a81970efeaa9d4e.exe included 1 qnumber 890830 product {Windows Server 2012 R2 (MU)} superced N installcmdline {} reboot {} installorder {} pposted 20181109T02:12:39Z verifiedOn 2018-11-23T12:21:00Z currentStatus 0 comments {} bytesNeeded 0 filesNeeded 0 isodate {} zrscsig {}
20181123 13:29:48 Info: Missing Count 0
20181123 13:29:48 Error: can't read "obj(PEXPINS)": no such element in array
while executing
"string is true -strict $obj(PEXPINS) "
("verify" arm line 4)
invoked from within
"switch -- $request {
update -
repair -
create { lassign [eval [linsert $obj(OCREATE) 0 $obj(OTYPE)::create $obj(..."
20181123 13:29:48 Warning: Error executing verify method for patch : can't read "obj(PEXPINS)": no such element in array
20181123 13:29:48 Info: Bulletin: MS-KB890830, Patch Name: , Status Code: 8, Status Message: Error executing verify method for patch : can't read "obj(PEXPINS)": no such element in array


I didn't find anything like PEXPINS anywhere in LIB except this error messsage.



2 0
Scott Gray
[800] [Internal Error] - During Proxy Preload

We have a number of Satellite servers reporting error 800 when performing a proxy preload.

20181029 11:06:10 Info: RPS/Static: synchronizing with radia://RPS_A04SLOAP023@clientmgmt-tier2:3464
20181029 11:06:10 Info: Searching SSL certificate and key files: E:/RCA/ApacheServer/conf/ssl/server.crt, E:/RCA/ApacheServer/conf/ssl/server.key
20181029 11:06:10 Error: SSL certificate and key files - E:/RCA/ApacheServer/conf/ssl/server.crt and E:/RCA/ApacheServer/conf/ssl/server.key - could not be found.
20181029 11:06:10 Info: RPS/Static: dispatching: E:/RCA/ProxyServer/bin/rps/radskman d=1,uid=RPS_A04SLOAP023,ip=clientmgmt-tier2,port=3464,datauri=http://clientmgmt-tier2:3466,preload=E:\RCA\DATA\ProxyServer\static,d=1
20181029 11:09:32 Warning: RPS/Static: sync: Radskman rc:[800] [Internal Error] (CHILDSTATUS 10072 800)

It seems that this is happening when trying to cache the October DISCOVER_PATCH service

ctime    mtime    service_id    product    app_name    catgroup    errornum    event    status    del_time    ver_time    inst_time    fix_time    nvd_domain    nvd_class    jobid    cjobid    downl_time
2014-10-21 10:59:42.000    2018-10-29 11:16:58.000    DISCOVER_PATCH    NULL    Scanning for Patch Vulnerabilities    NULL    800    Update (Preload)    Internal Error    NULL    2018-10-28 03:00:17    2017-08-16 17:34:08    2018-10-28 03:00:17    PATCHMGR    ZSERVICE    MachineConnect    7848:20    NULL

In some cases, we have been able to resolve this by manually syncing the servers (i.e. nvdkit sync-server.tcl -metadata 0 -resources 1)

We are currnetly running the following version:

module nvdkit        build   700.21     20160929 12:50:30 UST
module bin/unzip     version 6.0        20160929 13:16:53 UST
module bin/zip       version 3.0        20160929 13:16:53 UST
module lib/iocpsock  version 3.0        20160929 13:16:54 UST
module lib/itcl      version 3.3        20160929 13:16:51 UST
module lib/ldap      version 3.4        20160929 13:16:53 UST
module lib/ldaps     version 3.4        20160929 13:16:53 UST
module lib/mk        version    20160929 13:16:54 UST
module lib/nvdbase   version 3.0        20160929 13:16:52 UST
module lib/nvdkit    version 20160929 13:16:51 UST
module lib/openldap  version 2.4.23     20160929 13:16:53 UST
module lib/openssl   version 1.0.2j     20160929 13:16:51 UST
module lib/sqlite3   version 3.6.10     20160929 13:16:54 UST
module lib/tbcload   version 1.4        20160929 13:16:54 UST
module lib/tcl8.4    version 8.4.13     20160929 13:16:51 UST
module lib/tclodbc   version 3.0        20160929 13:16:54 UST
module lib/tclx      version 8.4        20160929 13:16:54 UST
module lib/tdom      version 0.8.2      20160929 13:16:51 UST
module lib/thread    version 2.6.5      20160929 13:16:51 UST
module lib/tls       version 1.6.7      20160929 13:16:51 UST
module lib/tnc       version 0.3        20160929 13:16:51 UST
module lib/trf       version 2.1        20160929 13:16:54 UST
module lib/udp       version 1.1        20160929 13:16:54 UST
module lib/vfs       version 1.3        20160929 13:16:51 UST
module lib/zlib      version 1.2.3      20160929 13:16:53 UST
dmabatch: 8.4.700.21
dcs.tkd build: 150
rps version: 09.21.0000 build 92782

Any ideas or suggestion on what could be causing this behaviour?


0 0
Casey Brennan
Applications in Self-Service Manager not showing as installed, even though they are

Has anyone ever seen the catalog not accurately showing applications as installed, even though they are?  We recently upgraded from 10.0 to 10.0 CP1, so there is a new RadUIShell.exe -- could this be the problem?  But not everyone is seeing the problem.  Any comments or experiences are appreciated. We looked at ZAVIS in ASERVICE.xml and it appears the values were reset to YXNX for the installed services.  Very strange. 

1 0
Scott Gray
RADIA - Package Reboots and File Base Write Filter

We are running HP Thin Clients in our environment, utilizing the file based write filter. There is a package which we need to install on these thin clients, this requires a reboot post installation to complete.

We currently have the reboot flag on the package set to AI=SA,AD=SA

The ZCREATE does not force a reboot.

We need to ensure the following:

  • Software connect is issued, write filter is turned off and device rebooted
  • Package installs, and causes the Thin Client to reboot (with write filter off so that the installation can complete)
  • Software connect continues when devices is back up
  • Once connect has fully completed, write filter is turned back on and device rebooted

We have tried changing the ZCREATE method so that it causes a device reboot, but the agent doesn’t take too kindly to this. The software connect does not complete after the device comes back online, and the write filter remains disabled.

How can we instruct the agent to reboot the device after installing the package, to complete the installation, whilst maintaining the FBWF?

Note: We are running 8.1

4 0
Marko Vlaovic
"Prohibited software" feature mentioned in official Radia presentation PPT - really? how, where?


As an Accelerite partner, i came accross a PPT presentation on the Accelerite Support site, titled "Technical-Overview-Radia2014". I see that this a rather old PPT but it is still available on the support site so i take it to be valid.

Slide 37 in that presentation is titled "Prohibited Software" and it talks about the feature to "Identify and block unapproved or prohibited software" using "prohibition rules". It also mentions that Radia management agent can "Identify prohibited software from Blacklist" and "Stops prohibited software form running each time user attempts to launch".

Since the concept of strict control over software installation is something many customers are interested in, this caught my attention as i have been working with older Radia on several projects and i have never seen such a feature in the product, or at least i don't remember.

So, is this really possible to Radia to handle "prohibited software" and if yes, what RCA module, feature, objects or mechanisms are used to support this? Is this a part of Usage Management?

Please point me in the right direction, how and where in the RCA system to configure the control over "prohibited software"?

Is this and explicit RCA feature or just an implicit cool thing you could indirectly construct out of standard RCA objects and features?

(of course, i wasn't able to find any clue in the official product manuals, no "prohibition rules" or anything like that is mentioned there)

Any guidance would be appreciated, thanks



3 0
Jeroen Peereboom
MSSQL 2016 and Radia 9.10


Where can I find if Radia 9.10 supports MSSQL 2016 (as Inventory Management database).


Jeroen P.

1 0
Vivek Chaudhary
Radia 7.9


I would like to understand what is involved in upgrading from Radia 7.9 to Radia 10.x.

  1. What is the migration path
  2. Do I need new Infra?
  3. Do I need to do anything with existing packages or will they work with Radia 10.x
  4. Do I need to do anything from Radia perspective if I move from Win 7 to Win 10 as well?
  5. Also, Do I need to pay for any license fee?

You can call me to discuss the details.




2 -1
Paweł Korpisz
Multiple values in ZSTOP


Is there an option to use OR switch in ZSTOP parameters?


6 0
Richard Phi Cutmore
Powershell Modules

Is there currently or plans to support powershell in future releases for Radia. As many modern technologies have taken this root we have been able to automate many tasks, saving time and reducing human error.

If this is not currently the case I would interested in building my own modules is there any API documentation that can be released? 




4 1
Richard Phi Cutmore
Radia 8.1 FBWF Issue

We have a model of thin client where the FBWF is not being re-Enabled during the overnight connect. 

After the device is built the filter is on due to a package that enabled and sets the filters exclusions list by the morning the filter set back to off.

Is there any known issue with the 8.1 agent or configuration that could cause this? 


1 0
Workstation rebuild

When Machine is built it gets the old hostname rather than new. Old hostname has been removed from SQL, HPCA and AD. Upload logs indicate the machine is built but it has been assigned the old hostname.

11 0
Bassel Desoky
Radia 10 Download Issue


I am trying to download Radia 10, however the download speed is really slow/not stable at all and it usually stops due to network errors. Can someone please provide a download link on external provider or something

0 1
Integration with HP uCMDB

Hi Team,

Could you please let me know whether the RCA 9.2 can be integration with HP uCMDB, we want to integrate this for asset information, if this can be possible could you suggest the document or link to refer for more information.


0 0
Bhupenderk Singh
How to acquire the MS Windows Patches for the month of April & May 2017

Microsoft's changed the way they number their bulletins. The previous model used security bulletin ID numbers; this method is being retired, and the new security bulletins will be identified by vulnerability ID numbers and KB Article ID numbers.

Kindly extend your support to acquire the new security bulletins,


Thanks & Regards,


+91 9805004140

1 0
Mahmoud Shash
CAE Agent deployment error

Dears ,

I have migrate the CAE core into another domain and since then I can't deploy an agent when I troubleshot I found that it tries to access the old  CORE FQDN

what I missed ???

1 0
Paweł Korpisz
Extended Notify Security to remote notify for patches


I would like to execute remote command to download patches but I have applied "Extended Notify Security to validate remote notify" https://radiasupport.accelerite.com/hc/en-us/articles/203659824 and when I type Radntfyc.exe localhost -l Token -p PASSWORD -e ENCRYPT Token it use command from the ZNFYCMDL Radntfyc localhost radskman ip=<core-ip>,dname=software,uid=$machine,cop=y,log=connect.log.

There is other way to run command remotely to agent to download patches (not software)?

Should I use some special switches for Radntfyc.exe or add special values for class Extended Security Notify in CSDB?

11 0
Vijayan Murugesan
Windows 10 support

Does RCA 9.1 CP1 will support windows 10 and windows 2012 versions? In the RCA 9.1 CP1 Release notes I could not find any update about windows 10 support.

1 0
Nebojša Popović
Timeout for software connect on group Radia Client Automation

We have an issue when we enforce software connect on group of 300 computers. We see that some of computer from group never get software
connect, they just timeout. Software connect for individual computer works fine but when we enforce software connect on 300 computers
only 50-60% actually gets software connect.
Is there a way to define timeout interval for computer and number of retries if computer is offline?

1 0
Tuncay Donmez
Ms16-142 Deploying Bulletin Problem

Hi guys,

We have some problems installing ms16-142 from radia. The problem is that clients have a message ' PATCH RISK Bulletin MS16-142 - risks have been detected '
NOTE : When we manually installed ms16-142, there is not a problem.

Well, how can we resolve this problem ? Have you any idea ?


2 0
Arash Kermanpour
Path and file buffer size


I have a service with deep path promoted successfully in Radia 9.2. It's published using Windows installer / basic mode. The problem is during deployment, client (Ver. 9.20) can not resolve the file name because of the buffer size limit of 260 as stated in the Connect log:

NVD005012E [get_resource_fi] 13:01:40 [RADCONCT / 000016bc] SYSTEM --! Path ["C:\PROGRA~1\Novadigm\Lib\SYSTEM\RADIA\software\ZSERVICE\MTO_ADK_ACAD2016_20X0_00\"\]
and file [AC32\acadMTO\Img\x86\Components\BIM360\Autodesk\ApplicationPlugins\AutoCAD2016Addin.bundle\Contents\Win32\PFiles\CommFiles\Autodesk Shared\Uninstall Tool\R1\UninstallEngine.dll]
does not fit in buffer of [260] size
NVD006001E [load_delta_entr] 13:01:40 [RADCONCT / 000016bc] SYSTEM --! Error resolving resource name from server object [MSIBASIC]

I appreciate if anybody shares a solution or workaround for this.


1 0
how a job is run?

i want to know when we push any job and system is shutdown at that time

when job will be run?

i mean to say after some time the system is in live mode at that time job is run or not?

0 0
Douglas Davis
9.2 Messaging server

It's been a few versions of radia sense I've looked at the Messaging server configuration files and I need some clarifications/definitions of how it works.

My goali is to enable a secondary server for forwarding messages to. 

I know in the rms.cfg file, I can add a PRI 20 in the  mgs::register Forward {}  section to have a secondary server for forwarding messagings to, but what I don't understand is other sections of the rms.cfg, like msg::register MDM, I also see forward statements of PRI 10. If I was using MDM, would I needd to add in a PRI 20 for a secondary server also?


Also, what defines in the RMS.cfg if the machine is a forwarder or poster (writes to ODBC).


1 0
Vasilije Radulovic
Radia Editor
I have a few questions about work in Radia Editor: 1. Can I select and then add/Replace/Delete multiple files in package? (How if it can?) 2. I want to see or to get a Folder Structure in Editor not just a lot a files, when I open package. Regards Thanks in advance
1 0
Libor Janda
LDAP authentication at Satellite
Hello all, do someone have any experience and/or tips and tricks for setting MS AD (LDAP) authentication for Satellite (especially in Radia 9.1)? Even though the configurations is really simple I've got two different behavior at two different systems. At one systems I can configure LDAP Auth, it configures Apache and simple doesn't work - I can't get to Sat web UI by domain login neither by admin login. At second system I'm unable to configure LDAP Auth at all, it just tell me that it can't connect LDAP, but from server I can ping and telnet domain controllers.
4 0
Getting permission Error while software deployment .

Getting error :- A program might need information from you or your permission to complete a task Zcreate installation method : "NATIVE C:\DLP_ENDPNT_WIN8\installagent64.bat"

1 1
Getting error code 653 when synchronization between full stream satellite sever and local satellite server
Not able to to sync downstream satellite server from full stream server .from core its working Error code 653
0 1
clinets are not dowloading datafrom local Repository (local satelite server )
When I run any deployment ( patch, audit) clients are not downloading the data from local repository (sateliete server ).
0 0

Top Contributors