Logo
 
 

CPBM backward compatibility support matrix

 
 
 
 
The following table lists the backward compatibility support matrix for Accelerite CPBM adaptations:
ComponentMajor version

(for example 2.0 -> 3.0)

Minor version

(for example: 2.1 -> 2.2)

Maintenance release

(for example: 2.2.1 -> 2.2.2)

Customization Repository

(CPBM UI Adaptations, Workflows, Message strings, and so on)

No No Yes

(Merge recommended)

Accelerite CloudPlatform Connector UI Fragment Repository No No Yes

(Merge recommended)

Note: This is not supported for Connector feature releases like 2.2.1
Cloud Connector SDK No Yes Yes
OSS Connector SDK No Yes Yes
 

Connector SDK

All connector APIs are fully backward compatible but the UI code (JSP, JS CSS, and so on) requires merge in every feature (dot) release.

Merging is not required in maintenance releases, but it is recommended to merge in order to get all bug fixes.

 

BSS APIs

All BSS APIs are fully backward compatible.

 

Customization SDK

Customization SDK code is backward compatible only in maintenance releases and requires a merge in every feature release. It is recommended to merge even for maintenance releases in order to get all bug fixes.

 
他にご質問がございましたら、リクエストを送信してください

コメント

 
Adding comment, please wait....

Provide Feedback on Article:

Subject:
Comments:*
Powered by Zendesk