Community
 
 
 

Radia Support

720 followers
 
Avatar
Libor Janda

LDAP authentication at Satellite

Hello all, do someone have any experience and/or tips and tricks for setting MS AD (LDAP) authentication for Satellite (especially in Radia 9.1)? Even though the configurations is really simple I've got two different behavior at two different systems. At one systems I can configure LDAP Auth, it configures Apache and simple doesn't work - I can't get to Sat web UI by domain login neither by admin login. At second system I'm unable to configure LDAP Auth at all, it just tell me that it can't connect LDAP, but from server I can ping and telnet domain controllers.
4 comments
0

Please sign in to leave a comment.

 
 

Previous 4 comments

Avatar
Gowhar Jan

Are you using LDAP over SSL?

You may want to check the AuthGroupDN you entered just to verify it is an actual group DN and not the default Users container DN. I did that more than once. This will be stored in your Apache httpd.conf file, look under the AuthLDAP section. If it needs correction, just make the change and restart Apache server.

The user name syntax for login is user@domain.suffix.

Comment actions Permalink
Avatar
Libor Janda

Hi Jan,

LDAP is connected without SSL on standard port 389 - that works at Core of both systems. I've found Apache config, but I have no working  template to compare with. And at second system Satellite refuses to save changes to Apache config, so I would configure Apache and service manually.

BTW if correct login has full domain suffix with dot, how do you configure access to CSDB? On Core that work with short directory service name.

Comment actions Permalink
Avatar
Gowhar Jan

The satellite authentication from LDAP source is only meant for controlling access to the Satellite console. It does not affect CSDB access.

Comment actions Permalink
Avatar
Libor Janda

Thanks Jan,

CSDB access I can set through edmprof.

Comment actions Permalink

Top Contributors