Community
 
 
 

CloudPortal Business Manager 1.x

342 followers
 
Avatar
Administrator

about Integrate cpbm 1.4.5 and cpman 3.0.6

Avatar

about Integrate cpbm 1.4.5 and cpman 3.0.6

I installed the cpman 3.0.6 successful and want integrate with cpbm. My cpbm version is 1.4.5.

Following is my topology and configuration
192.168.9.157: cpbm (CentOS 6.4 x64, cpbm 1.4.5)
192.168.9.160: cpman(Redhat 6.3 x64, cpman 3.0.6)

.160 - cpman:
ntpd configure
integration.api.port = 8096
install cloud usage monitor
configure database (cpbm, Citrix123)
disable iptables
install "integrate with cloudstack" option (Cloudportal)

.157 - cpbm:

install httpd, sendmail, ntpd and configure
disable iptables
install database server (option D) and configure database user "cloud" /cloud
install CloudPortal Business Manager (option I) successful and configure cloud.properties

I reference this guide "Build your own highly scalable and reliable Amazon-style cloud in 1 day with Citrix CloudPlatform"...But something errors are created in /var/log/cloud/portal/catalina.out
one is "the log time is error ",i checked both cpman&cpbm systems with "date" command ,same time is for both systems. My date is
" Mon Apr 1 10:02:51 CST 2013" for both systems,, but i execute "service cloud-portal restart" and check the log file again, the date is
" Apr 1, 2013 2:05:25 AM"
The other is ,?execute "http://192.168.9.157/portal" from IE 10,The Output is " Cannot display"...I look out the log file (catalina.out),i can find
the " Apr 1, 2013 2:05:25 AM org.apache.catalina.startup.Catalina start INFO: Server startup in 31259 ms", The cloud portal sees fine..
But I cannot see the correct "login" web page How cat i resolve the problems?

Attached Files


robin dun MEMBERS 01 April 2013 - 05:59 AM
4 comments
0

Please sign in to leave a comment.

 
 

Previous 4 comments

Avatar
Administrator
Avatar

about Integrate cpbm 1.4.5 and cpman 3.0.6

Hi Robin,

The time difference you see in the log file and the OS could be because the CPBM Server by default runs on GMT and your OS is running on CST.

I am seeing some database errors also in the log file. Can you please drop and recreate the "cloud_reports" database as shown below and restart the CPBM server
_To drop and recreate reports database_
Login to CPBM MYSQL database
mysql > drop database cloud_reports;
mysql > create database cloud_reports;

_To restart CPBM server_
$ service cloud-portal restart

Once CPBM is successfully restarted then please check the following :
# Try to connect to CPBM server directly bypassing the apache proxy, "http://192.168.9.157:8080/portal/portal/". If you see the CPBM login page then it confirms that CPBM server is up and running. Else send the latest CPBM logs (catalina.out) .
# If above works then try to connect to CPBM server via proxy, "http://192.168.9.157/portal/portal/". If you see login page then it confirms that apache proxy is configured correctly. Else follow the steps to setup proxy server at: http://support.citrix.com/proddocs/topic/cloudportalbusiness-14/ccpb-install.html .

Thanks,
Manish


Manish Agarwal CITRIX EMPLOYEES 01 April 2013 - 06:26 AM
Comment actions Permalink
Avatar
Administrator
Avatar

Dear Manish:
The result is the same ....I send the latest CPBM logs.....Thanks

Attached Files


robin dun MEMBERS 01 April 2013 - 06:48 AM
Comment actions Permalink
Avatar
Administrator
Avatar

Hi Robin,

I checked the latest logs. This time the cloud_reports database got populated successfully.
The error in the logs is "java.lang.Exception: Socket bind failed: [13] Permission denied".
Which means there is some permission issue while starting the CPBM server.

Did you make any change in server.xml located at: /usr/share/cloud/portal/conf/ directory?

But from the logs it seems the AJP port got started, can you also try configuring the proxy to redirect request over ajp?
Documentation for redirecting to AJP is also available at : http://support.citrix.com/proddocs/topic/cloudportalbusiness-14/ccpb-install.html

Thanks,
Manish


Manish Agarwal CITRIX EMPLOYEES 01 April 2013 - 07:08 AM
Comment actions Permalink
Avatar
Administrator
Avatar

Dear Manish:
i change /etc/cloud/portal/server.xml file. Change the line:
<Connector port="20410" protocol="AJP/1.3" redirectPort="8443"/>
To:
<Connector port="20410" protocol="AJP/1.3" redirectPort="8443" secure="true"

I have changed again the server.xml to original setting & I can log in portal .....
Thanks for your help


robin dun MEMBERS 01 April 2013 - 07:23 AM
Comment actions Permalink

Top Contributors