CloudPortal Business Manager 1.x

 
 
Administrator
cloudPlatform: User signature is not equaled to computed signature test
Hi,

I'm trying to setup CPBM 1.4.7-1 to run against CP 3.0.6-1, but for some reason the "user signature" is lowercase version of the "computed signature", and hence they are not equal to each other, and the authentication fails. I have already followed the troubleshooting tips at: http://support.citrix.com/proddocs/topic/cloudportalbusiness-14/ccpb-troubleshoot.html with no luck. Any ideas why the case difference between the signatures might be occuring?

 INFO  [cloud.user.AccountManagerImpl] (catalina-exec-8:) User signature: ebuyjx6/sc9m5j4fxk7uubie3qs= is not equaled to computed signature: EBuYjx6/SC9m5J4fxK7UubIe3qs= 

WARN  [cloud.api.ApiServer] (catalina-exec-19:) The given command:listzones does not exist

 INFO  [cloud.user.AccountManagerImpl] (catalina-exec-1:) User signature: x0ogmbeq3cn9jwvdhydt/ogjjpm= is not equaled to computed signature: x0OgMBEq3Cn9JWVdHYdT/OGJjpM= 

5 0
Administrator
CPBM 1.4.7: problems sending email
Avatar

CPBM 1.4.7: problems sending email

Hi All.

 

I have recently installed CPBM 1.4.7.  I can login as root fine and create some accounts/users, but the users show up as "disabled" and do not appear to receive a verification email.  When I go to the user detail screen and select "Re-Send Verification", it says "Re-send email verification succeeded" but no email is received and log indicates an error:

 

WARN  27 Nov 2013 06:45:39,913:[QueueListener-1:DefaultMessageListenerContainer][] Execution of JMS message listener failed, and no ErrorHandler has been set.
org.springframework.jms.support.converter.MessageConversionException: Could not unmarshal message: ActiveMQTextMessage {commandId = 5, responseRequired = true, messageId = ID:phillip2.its.unimelb.edu.au-53859-1385534738513-0:1:1:1:1, originalDestination = null, originalTransactionId = null, producerId = ID:phillip2.its.unimelb.edu.au-53859-1385534738513-0:1:1:1, destination = queue://vmops.notification.queue, transactionId = null, expiration = 0, timestamp = 1385534739669, arrival = 0, brokerInTime = 1385534739672, brokerOutTime = 1385534739742, correlationId = null, replyTo = null, persistent = true, type = null, priority = 4, groupID = null, groupSequence = 0, targetConsumerId = null, compressed = false, userID = null, content = null, marshalledProperties = null, dataStructure = null, redeliveryCounter = 0, size = 0, properties = null, readOnlyProperties = true, readOnlyBody = true, droppable = false, text = <com.vmops.event.VerifyEmailRequest><username...mailRequest>}; nested exception is org.springframework.oxm.UnmarshallingFailureException: XStream unmarshalling exception; nested exception is com.thoughtworks.xstream.converters.ConversionException: Cannot construct com.vmops.event.VerifyEmailRequest as it does not have a no-args constructor : Cannot construct com.vmops.event.VerifyEmailRequest as it does not have a no-args constructor
---- Debugging information ----
message             : Cannot construct com.vmops.event.VerifyEmailRequest as it does not have a no-args constructor
cause-exception     : com.thoughtworks.xstream.converters.reflection.ObjectAccessException
cause-message       : Cannot construct com.vmops.event.VerifyEmailRequest as it does not have a no-args constructor
class               : com.vmops.event.VerifyEmailRequest
required-type       : com.vmops.event.VerifyEmailRequest
path                : /com.vmops.event.VerifyEmailRequest
line number         : 1
-------------------------------
        at org.springframework.jms.support.converter.MarshallingMessageConverter.fromMessage(MarshallingMessageConverter.java:188)
        at org.springframework.jms.listener.adapter.MessageListenerAdapter.extractMessage(MessageListenerAdapter.java:407)
        at org.springframework.jms.listener.adapter.MessageListenerAdapter.onMessage(MessageListenerAdapter.java:345)
        at org.springframework.jms.listener.adapter.MessageListenerAdapter.onMessage(MessageListenerAdapter.java:330)
        at org.springframework.jms.listener.AbstractMessageListenerContainer.doInvokeListener(AbstractMessageListenerContainer.java:535)
        at org.springframework.jms.listener.AbstractMessageListenerContainer.invokeListener(AbstractMessageListenerContainer.java:495)
        at org.springframework.jms.listener.AbstractMessageListenerContainer.doExecuteListener(AbstractMessageListenerContainer.java:467)
        at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.doReceiveAndExecute(AbstractPollingMessageListenerContainer.java:325)
        at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.receiveAndExecute(AbstractPollingMessageListenerContainer.java:263)
        at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.invokeListener(DefaultMessageListenerContainer.java:1058)
        at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.executeOngoingLoop(DefaultMessageListenerContainer.java:1050)
        at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.run(DefaultMessageListenerContainer.java:947)
        at java.lang.Thread.run(Thread.java:744)
Caused by: org.springframework.oxm.UnmarshallingFailureException: XStream unmarshalling exception; nested exception is com.thoughtworks.xstream.converters.ConversionException: Cannot construct com.vmops.event.VerifyEmailRequest as it does not have a no-args constructor : Cannot construct com.vmops.event.VerifyEmailRequest as it does not have a no-args constructor

 

 

My configuration in /etc/cloud/portal/cloud.properties is:

 

# Mail sender (SMTP/SMTPS) configuration                                       #
vmops.mail.protocol=smtp
vmops.mail.host=smtp.our.domain
vmops.mail.port=25
vmops.mail.username=
vmops.mail.password=

 

I can telnet to port 25 on smp.our.domain from the CPBM host successfully.

 

Any ideas what the issue might be here?

 

Regards,

 

Robert.


Robert Sturrock MEMBERS 27 November 2013 - 06:52 AM
1 0
Administrator
Error: "User signature is not equaled (sic) to computed signature"
Avatar

Error: "User signature is not equaled (sic) to computed signature"

HI All.

 

I'm trying to setup CPBM 1.4.7 to run against CP 3.0.6.  CPBM starts up, I can login as root, but the dashboard fails to render.  The catalina.out log on CP shows a stream of these messages:

 

2013-11-21 16:03:41,669 INFO  [cloud.user.AccountManagerImpl] (catalina-exec-23:null) User signature: XXXXXXXXXXXXXXX/M8+4I= is not equaled to computed signature: YYYYYYYYYYYYYYRnjTp4=

 

 

Meanwhile, catalina.out on the CPBM server says:

 

DEBUG 21 Nov 2013 05:47:02,765:[http-8080-7:CloudStackApiController][] api proxy: json error string: {"listzonesresponse":{"errorcode":401,"errortext":"unable to verify user credentials and\/or request signature"}}
ERROR 21 Nov 2013 05:47:02,878:[http-8080-7:HomeController][] ###Error while setting Service Health: com.vmops.service.exceptions.CloudServiceException: Cloud Account is required to execute cloudstack API.

 

 

Any thoughts on what the issue might be here?

 

Regards,

 

Robert.


Robert Sturrock MEMBERS 21 November 2013 - 05:48 AM
2 0
Administrator
Upgrade CCPM 1.4.6 to 2.1
Avatar

Upgrade CCPM 1.4.6 to 2.1

I am running Xenserver 6.1 - CCP 3.0.6 - CPBM 1.4.6, I am willing to upgrade to newer versions as:

Xenserver 6.2
CCP 4.2
CPBM 2.1

what is the best to do so, is it with one shot? or to upgrade portal then platform then xenserver?
if the second, so can I run CPBM (2.1) on CCP 3.0.6 and Xenserver 6.1 for a while before completing the upgrade?

Your advice and recommendation is appreciated.

Tamer

Edited by: tamer@encloud-me.com on Oct 28, 2013 9:53 AM


Tamer Al-Kabani MEMBERS 28 October 2013 - 05:42 AM
0 0
Administrator
Launched Vm Password email subject
Avatar

Launched Vm Password email subject

Hello,

I am running CloudPortal 1.4.6, as if I launch more than one VM then I will receive emails of their password with the same number of launched VMs.

The problem is:

the mail subject is the same for all sent emails which is "VM Password Notification", so if I want to change the subject to the "launched VM name" how it could be done.

Note: the portal is running on Linux CentOs.

Attached pic may clear the idea.

Regards,

Attached Files


Tamer Al-Kabani MEMBERS 08 October 2013 - 13:03 PM
4 0
Administrator
Tab Title Change
Avatar

Tab Title Change

Hello;

I am running CloudPortal business manager 1.4.6 in Linux Centos.

Problem:

I want to change the browser tab title to something else.

File example is attached.

Direct solution is appreciated (without work around solution).

Many thatnks

Attached Files


Tamer Al-Kabani MEMBERS 02 October 2013 - 13:15 PM
2 0
Administrator
CPBM traffic billing
Avatar

CPBM traffic billing

Hi All,

In CPBM we have "Network Bandwidth" as a listed product, this product tracks outgoing traffic from the VR public side interface only?


Edward Valencia MEMBERS 04 September 2013 - 18:55 PM
3 0
Administrator
javax.mail.MessagingException: Can't send command to SMTP host; nested exception is:
Avatar

javax.mail.MessagingException: Can't send command to SMTP host; nested exception is:

Hello,

I am not able to send mail to users for account activation etc.

The error message i get is as follows :

javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. Failed messages: javax.mail.MessagingException: Can't send command to SMTP host;
nested exception is:
javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Caused by: javax.mail.MessagingException: Can't send command to SMTP host
Caused by: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)
Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

========================
End of log.

Please help .

regards

VincentS


Faustina Glory MEMBERS 19 August 2013 - 14:25 PM
1 0
Administrator
Image/User Issues
Avatar

Image/User Issues

Hi guys,

I installed BusinessManager 1.4.6 on one of my servers. So far everything seemed to be working fine. Now I tried to change an image of one of my product bundles. When I try this Google Chrome returns a window with null. Other browsers like safari or IE even don't show an error.

Same thing happened when I tried to register a new user.

Does anyone have an idea what I could have done wrong?

with best regards

Markus


Markus Gabriel MEMBERS 06 August 2013 - 14:04 PM
6 0
Administrator
cloud portal 1.4.6 not lauching cloud console
Avatar

cloud portal 1.4.6 not lauching cloud console

Hi all,
I installed cloud portal 1.4.6 and integrated it with cloud stack 3.0.6, but i cannot launch cloud console and I got this error in catalina.out

DEBUG 17 Jul 2013 17:30:33,382:[http-8080-1:DispatcherServlet][] Handler execution resulted in exception - forwarding to resolved error view: ModelAndView: reference to view with name 'errors/error'; model is {errorMessage=java.net.URISyntaxException: Illegal character in scheme name at index 4: http :///client/api?id=2&state=enabled&command=listUsers}
com.vmops.service.exceptions.CloudServiceException: java.net.URISyntaxException: Illegal character in scheme name at index 4: http :///client/api?id=2&state=enabled&command=listUsers
at com.vmops.cloud.client.impl.DefaultCloudServiceImpl.createCloudstackAdminUri(DefaultCloudServiceImpl.java:2478)
at com.vmops.cloud.client.impl.DefaultCloudServiceImpl.executeAsAdmin(DefaultCloudServiceImpl.java:1825)
at com.vmops.cloud.client.impl.DefaultCloudServiceImpl.listUsers(DefaultCloudServiceImpl.java:1179)
at com.vmops.service.impl.CloudManagementServiceImpl.verifyCloudAccount(CloudManagementServiceImpl.java:718)
at com.vmops.service.impl.CloudManagementServiceImpl.verifyAccount(CloudManagementServiceImpl.java:524)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:309)
at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:196)
at $Proxy120.verifyAccount(Unknown Source)
�.
Thanks
Lucas

Attached Files

  • Attached File  cpbm.png   152.02K   1 downloads

Lucas Vinturini MEMBERS 17 July 2013 - 17:36 PM
2 0
Gert Jensen
No default guest network offered ?

Hello again,

When i Try to create a VM i get "No default Network offered".

Where do i set the default network ?

Kind regards
Gert


3 0
Gert Jensen
CPBM 1.4.6 Bundles not showing

Hello,

I have created some VMs typed in prices, published, added them to a catalog,
but they are not showing for the customers, should i do more ?

The current settings are showing that they are published.

Kind regards
Gert


11 0
Gert Jensen
Installing 1.4.6

Hello,

I am about to install CPBM 1.4.6 should i still install Byron Compatibility Pack on the management server ?

Thanks.

Gert Jensen


1 0
Gert Jensen
When dows CPBM 1.4 have EOL

Hello,

When is CPBM 1.4 stopped beeing developed ?

i think i saw 31.06.2013 ?
is that correct ?

Kind regards
Gert


1 0
Peter Sadowski
Setting Terms and Conditions

What files need to be modified to set Terms and Conditions on the bottom of each CPBM page and the popup window where users agree to Terms and Conditions before they order a VM.

I'm running CPBM v1.4.5


6 0
Administrator
Email Template Values
Avatar

Email Template Values

Where do the values that get substituted into email templates get set? For example, ${service_name} and ${support_phone} in the welcome email get real values when an email is generated. But, I can't find where the values come from. Thanks.


Paul Welch MEMBERS 17 May 2013 - 16:07 PM
1 0
Administrator
Adding New CPBM Profiles
Avatar

Adding New CPBM Profiles

<p>Hi,</p><p><span style="font-size:10.5pt;"><span style="font-family:arial, sans-serif;"><span style="color:rgb(34,34,34);">How can we add more CPBM SP profiles to cater for different roles within the SP? I understand this is possible by adding the new profile name into the database first and then using the UI to select the roles assigned to the new profile? </span></span></span></p><p><span style="font-size:10.5pt;"><span style="font-family:arial, sans-serif;"><span style="color:rgb(34,34,34);">Is there a procedure for doing this? </span></span></span></p><p>Thanks</p><p>Stuart</p>


Stuart Jennings CITRIX EMPLOYEES 16 May 2013 - 10:41 AM
1 0
Administrator
CPBM 1.4.6 unable to view tenant details
Avatar

CPBM 1.4.6 unable to view tenant details

In CPBM 1.4.6, under Administration > Configuration > Server changing the vmops.portal.currency.format from ###,###.## to ###.###,## which is a required format for Brazil, results in the Admin user unable to view user account details under Accounts - just get a blank pane.

The catalina.out shows the following exception:

org.apache.tiles.impl.CannotRenderException: ServletException including path '/WEB-INF/jsp/tiles/tenants/viewtenant.jsp'.
at org.apache.tiles.impl.BasicTilesContainer.render(BasicTilesContainer.java:680)
at org.apache.tiles.impl.BasicTilesContainer.render(BasicTilesContainer.java:633)
at org.apache.tiles.impl.BasicTilesContainer.render(BasicTilesContainer.java:322)
at org.springframework.web.servlet.view.tiles2.TilesView.renderMergedOutputModel(TilesView.java:124)
at org.springframework.web.servlet.view.AbstractView.render(AbstractView.java:250)
at org.springframework.web.servlet.DispatcherServlet.render(DispatcherServlet.java:1047)
at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:817)
at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:719)
at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:644)
at org.springframework.web.servlet.FrameworkServlet.doGet(FrameworkServlet.java:549)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.springframework.web.filter.HiddenHttpMethodFilter.doFilterInternal(HiddenHttpMethodFilter.java:77)
at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:366)
at org.springframework.security.web.access.intercept.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:109)

Caused by: org.apache.tiles.util.TilesIOException: ServletException including path '/WEB-INF/jsp/tiles/tenants/viewtenant.jsp'.
at org.apache.tiles.servlet.context.ServletUtil.wrapServletException(ServletUtil.java:232)
at org.apache.tiles.servlet.context.ServletTilesRequestContext.forward(ServletTilesRequestContext.java:243)
at org.apache.tiles.servlet.context.ServletTilesRequestContext.dispatch(ServletTilesRequestContext.java:222)
at org.apache.tiles.renderer.impl.TemplateAttributeRenderer.write(TemplateAttributeRenderer.java:44)
at org.apache.tiles.renderer.impl.AbstractBaseAttributeRenderer.render(AbstractBaseAttributeRenderer.java:103)
at org.apache.tiles.impl.BasicTilesContainer.render(BasicTilesContainer.java:659)
at org.apache.tiles.impl.BasicTilesContainer.render(BasicTilesContainer.java:678)
... 72 more
Caused by: java.lang.IllegalArgumentException: Multiple decimal separators in pattern "###.###.##;(###,###.##)"
at java.text.DecimalFormat.applyPattern(DecimalFormat.java:2537)
at java.text.DecimalFormat.<init>(DecimalFormat.java:462)
at org.apache.taglibs.standard.tag.common.fmt.FormatNumberSupport.doEndTag(FormatNumberSupport.java:188)
at org.apache.jsp.WEB_002dINF.jsp.tiles.tenants.viewtenant_jsp._jspx_meth_fmt_005fformatNumber_005f0(viewtenant_jsp.java:3450)
at org.apache.jsp.WEB_002dINF.jsp.tiles.tenants.viewtenant_jsp._jspService(viewtenant_jsp.java:447)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:388)
at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313)
at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:646)
at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:436)
at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:374)
at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:302)
at org.apache.tiles.servlet.context.ServletTilesRequestContext.forward(ServletTilesRequestContext.java:241)

Attached Files


TARIQ IQBAL MEMBERS 26 April 2013 - 16:02 PM
3 0
Thura Minn minn
VM visibility between Users of Same Account

Hi,

I would like to set Normal Users in an account NOT to see VM created by other Users in that account.
Could that be possible?

Thanks,
Thura


1 0
Thura Minn minn
How to Change Labels in other Languages

Hi,

I would like to change some lables for japanese.
How can I change the label for other languages.

Thanks,
Thura


4 0
Administrator
Parameter detailed.billing.activity.file
Avatar

Parameter detailed.billing.activity.file

What folder does the billing activity file get created if I set parameter detailed.billing.activity.file to "Y"? Also, is there any information about the fields included in the file or file layout? Thanks.


Paul Welch MEMBERS 22 April 2013 - 22:40 PM
2 0
Administrator
CPBM 1.4.6 fails to start on Centos 6.3
Avatar

CPBM 1.4.6 fails to start on Centos 6.3

Installed CPBM 1.4.6 on a fresh install of Centos 6.3, but CPBM fails to start...

root@cpbm146 CloudPortal-1.4.6-1-centos# service cloud-portal start
Starting cloud-portal: [ OK ]

root@cpbm146 CloudPortal-1.4.6-1-centos# tail -f /var/log/cloud/portal/catalina.out
-sh: line 0: export: `.': not a valid identifier
-sh: line 0: export: `/etc/cloud/portal/tomcat6.conf': not a valid identifier
-sh: line 0: export: `.': not a valid identifier
-sh: line 0: export: `/etc/cloud/portal/tomcat6.conf': not a valid identifier
/usr/sbin/dtomcat6: line 30: /logs/catalina.out: No such file or directory

root@cpbm146 CloudPortal-1.4.6-1-centos# service cloud-portal status
cloud-portal dead but pid file exists


TARIQ IQBAL MEMBERS 21 April 2013 - 12:29 PM
2 0
Administrator
CPBM doc not showing v1.4.6 release notes
Avatar

CPBM doc not showing v1.4.6 release notes

The CPBM pdf documentation (http://citrix.edocspdf.com/media/output/en.cloudportalbusiness-14.ccpb-business-manager-14.pdf) does not show the release notes for v1.4.6

The PDF needs to be updated.


Tariq Iqbal MEMBERS 20 April 2013 - 10:36 AM
2 0
Administrator
Unable to install CPBM
Avatar

Unable to install CPBM

Hello,

i am unable to install cpbm.

When i run the instal script i get the following error messages during install.

Downloading Packages:
http://ftp.heanet.ie/pub/jpackage/6.0/generic/free/RPMS/tomcat6-6.0.33-2.jpp6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
http://mirror.ibcp.fr/pub/jpackage/6.0/generic/free/RPMS/tomcat6-6.0.33-2.jpp6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
http://mirrors.dotsrc.org/jpackage/6.0/generic/free/RPMS/tomcat6-6.0.33-2.jpp6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
http://sunsite.informatik.rwth-aachen.de/ftp/pub/Linux/jpackage/6.0/generic/free/RPMS/tomcat6-6.0.33-2.jpp6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
http://sunsite.rediris.es/mirror/jpackage/6.0/generic/free/RPMS/tomcat6-6.0.33-2.jpp6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 403"
Trying other mirror.
ftp://ftp.pbone.net/pub/jpackage/6.0/generic/free/RPMS/tomcat6-6.0.33-2.jpp6.noarch.rpm: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
ftp://gsa10.eps.cdf.udc.es/jpackage/6.0/generic/free/RPMS/tomcat6-6.0.33-2.jpp6.noarch.rpm: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
ftp://jpackage.hmdc.harvard.edu/JPackage/6.0/generic/free/RPMS/tomcat6-6.0.33-2.jpp6.noarch.rpm: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
http://ftp.heanet.ie/pub/jpackage/6.0/generic/free/RPMS/tomcat6-el-1.0-api-6.0.33-2.jpp6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying oth.

And then it finally fails with message :
error: Failed dependencies:
tomcat6 is needed by cloud-portal-1.4.5-1.x86_64
error: Failed dependencies:
cloud-portal is needed by cloud-portal-plugins-cas-1.4.5-1.x86_64

i realize that the mirror sites to download the packages are down or have some issues , but in this case what is the workaround.

Please help.

Regards

Vincent s


Faustina Glory MEMBERS 17 April 2013 - 09:33 AM
1 0
Administrator
CPBM 1.4 will not start
Avatar

CPBM 1.4 will not start

Hi all,
I've installed CPBM 1.4.2-1 on CentOS 6.3 with much difficulty but after the installation and configuration it'll not start. I get the following errors in the catalina.out log file:
-sh: line 0: export: `.': not a valid identifier
-sh: line 0: export: `/etc/cloud/portal/tomcat6.conf': not a valid identifier
-sh: line 0: export: `.': not a valid identifier
-sh: line 0: export: `/etc/cloud/portal/tomcat6.conf': not a valid identifier
/usr/sbin/dtomcat6: line 30: /logs/catalina.out: No such file or directory
-sh: line 0: export: `.': not a valid identifier
-sh: line 0: export: `/etc/cloud/portal/tomcat6.conf': not a valid identifier
-sh: line 0: export: `.': not a valid identifier
-sh: line 0: export: `/etc/cloud/portal/tomcat6.conf': not a valid identifier
/usr/sbin/dtomcat6: line 60: /logs/catalina.out: No such file or directory

When I do a "service cloud-portal status" I get a "cloud-portal dead but pid file exists" response. I believe the issue is linked to CentOS lsb because I couldn't install tomcat6 without installing redhat-lsb.

I've searched the forum but not come across anything like this. Has anyone had such an experience? Can anyone point me in the right direction?

TIA


Osay Osman Yuuni MEMBERS 16 April 2013 - 10:17 AM
9 0
Administrator
CloudProtal Business Manager Retail Account type "fail
Avatar

CloudProtal Business Manager Retail Account type "fail

Hi,all,
I install CPBM 1.4.5 and CloudPlatform 3.0.6 finish for POC Demo
I sign a Retail account

than , login as account and company setup
after input Credit Card information
display error message
fail to update payment d"etail,Please contace support"

Any settings I shoud modify it ? or check it ?

thanks

Aster


Aster Huang MEMBERS 15 April 2013 - 07:50 AM
3 0
Administrator
Add New button on the Products screen does not work
Avatar

Add New button on the Products screen does not work

In CPBM 1.4.5, logged in as root, under the Products tab when adding a new product by clicking the ‘Add New’ button nothing the happens - the 'Add new product' wizard does not appear. This occurs in both Firefox and IE browsers. As an aside, under the Product Bundles tab the 'Add New' buttons works fine.

Also noticed the portal version/build text at the bottom right of the screen reads: "v1.4.5 (${cloud.portal.build.id}" - the build id does not appear.


TARIQ IQBAL MEMBERS 10 April 2013 - 22:36 PM
3 0
Administrator
Portal time
Avatar

Portal time

Since Daylight Saving Time kicked in on Sunday in the UK, the OS is running on BST (eg. 18:00), however Portal appears to be running on UTC time (eg.17:00) - the messages in catalina.out are logged on UTC time as are the batch jobs.

The CP service and server has been restarted/rebooted, without no affect.

Where/how can the time used by portal be set to use BST?

Regards


TARIQ IQBAL MEMBERS 02 April 2013 - 18:26 PM
1 0
Administrator
Scheduling Batch Jobs
Avatar

Scheduling Batch Jobs

Tried to re-schedule the batch jobs in CPBM 1.4.5 by following the steps listed in the documentation (see below). The cronExpression property was changed in applicationContext-jobs.xml to the new execution time and the file was copied to “/usr/share/cloud/portal/webapps/admin/WEB-INF/classes/” - the CP service was restarted and eventually the server was rebooted. But the batch jobs continue to run on the original schedule, the new time is ignored.

Are the instructions correct or am I missing something?

Regards,

Scheduling Batch Jobs

1. Go to the /usr/share/cloud/portal/webapps/admin/WEB-INF/lib/ directory, copy the “vmops.admin-1.0-SNAPSHOT.jar” file to “/tmp” directory
2. Extract the jar file “vmops.admin-1.0-SNAPSHOT.jar”
3. Copy the “applicationContext-jobs.xml” and “applicationContext-scheduler.xml”
4. Edit "applicationContext-jobs.xml" and modify the XML elements for each job you want to work with. Typically, you will only edit the cronExpression property of an existing element. Follow the pattern in the file. If you need more help, see Job Scheduling Syntax in "applicationContext-jobs.xml".
5. Edit "applicationContext-scheduler.xml" and be sure that every trigger ID defined in "applicationContext-jobs.xml" is listed in the "triggers" property of the org.springframework.scheduling.quartz.SchedulerFactoryBean bean element. If you need more help, see Job Scheduling Syntax in "applicationContext-scheduler.xml."
6. Copy these to files to “/usr/share/cloud/portal/webapps/admin/WEB-INF/classes/”


TARIQ IQBAL MEMBERS 02 April 2013 - 16:28 PM
1 0
Administrator
about Integrate cpbm 1.4.5 and cpman 3.0.6
Avatar

about Integrate cpbm 1.4.5 and cpman 3.0.6

I installed the cpman 3.0.6 successful and want integrate with cpbm. My cpbm version is 1.4.5.

Following is my topology and configuration
192.168.9.157: cpbm (CentOS 6.4 x64, cpbm 1.4.5)
192.168.9.160: cpman(Redhat 6.3 x64, cpman 3.0.6)

.160 - cpman:
ntpd configure
integration.api.port = 8096
install cloud usage monitor
configure database (cpbm, Citrix123)
disable iptables
install "integrate with cloudstack" option (Cloudportal)

.157 - cpbm:

install httpd, sendmail, ntpd and configure
disable iptables
install database server (option D) and configure database user "cloud" /cloud
install CloudPortal Business Manager (option I) successful and configure cloud.properties

I reference this guide "Build your own highly scalable and reliable Amazon-style cloud in 1 day with Citrix CloudPlatform"...But something errors are created in /var/log/cloud/portal/catalina.out
one is "the log time is error ",i checked both cpman&cpbm systems with "date" command ,same time is for both systems. My date is
" Mon Apr 1 10:02:51 CST 2013" for both systems,, but i execute "service cloud-portal restart" and check the log file again, the date is
" Apr 1, 2013 2:05:25 AM"
The other is ,?execute "http://192.168.9.157/portal" from IE 10,The Output is " Cannot display"...I look out the log file (catalina.out),i can find
the " Apr 1, 2013 2:05:25 AM org.apache.catalina.startup.Catalina start INFO: Server startup in 31259 ms", The cloud portal sees fine..
But I cannot see the correct "login" web page How cat i resolve the problems?

Attached Files


robin dun MEMBERS 01 April 2013 - 05:59 AM
4 0

Top Contributors