Community
 
 
 

CloudPortal Business Manager 1.x

342 followers
 
Avatar
Administrator

CPBM 1.4 will not start

Avatar

CPBM 1.4 will not start

Hi all,
I've installed CPBM 1.4.2-1 on CentOS 6.3 with much difficulty but after the installation and configuration it'll not start. I get the following errors in the catalina.out log file:
-sh: line 0: export: `.': not a valid identifier
-sh: line 0: export: `/etc/cloud/portal/tomcat6.conf': not a valid identifier
-sh: line 0: export: `.': not a valid identifier
-sh: line 0: export: `/etc/cloud/portal/tomcat6.conf': not a valid identifier
/usr/sbin/dtomcat6: line 30: /logs/catalina.out: No such file or directory
-sh: line 0: export: `.': not a valid identifier
-sh: line 0: export: `/etc/cloud/portal/tomcat6.conf': not a valid identifier
-sh: line 0: export: `.': not a valid identifier
-sh: line 0: export: `/etc/cloud/portal/tomcat6.conf': not a valid identifier
/usr/sbin/dtomcat6: line 60: /logs/catalina.out: No such file or directory

When I do a "service cloud-portal status" I get a "cloud-portal dead but pid file exists" response. I believe the issue is linked to CentOS lsb because I couldn't install tomcat6 without installing redhat-lsb.

I've searched the forum but not come across anything like this. Has anyone had such an experience? Can anyone point me in the right direction?

TIA


Osay Osman Yuuni MEMBERS 16 April 2013 - 10:17 AM
9 comments
0

Please sign in to leave a comment.

 
 

Previous 9 comments

Avatar
Administrator
Avatar

CPBM 1.4 will not start

Running into the same issue on 2 fresh CentOS 6.3 boxes.


Shanker Balan MEMBERS 19 April 2013 - 07:24 AM
Comment actions Permalink
Avatar
Administrator
Avatar

Kindly use the latest CPBM version (1.4.6).

Can you check whether you are able to resolve CPBM hostname to IP?

nslookup <your hostname>
nslookup localhost

Can you share the tomcat.conf, cloud.properties and catalina.out for us to comment?


Madan Ganesh Velayudham CITRIX EMPLOYEES 19 April 2013 - 07:51 AM
Comment actions Permalink
Avatar
Administrator
Avatar

Hi Madan

This is with CPBM 1.4.6.

[root@pre-srvcloudport01 portal]# host `hostname -f`
pre-srvcloudport01.xxx has address 10.26.0.31
[root@pre-srvcloudport01 portal]#


Shanker Balan MEMBERS 19 April 2013 - 07:55 AM
Comment actions Permalink
Avatar
Administrator
Avatar

Hi,

I went on to CPBM 2.0.1 and everything is honky dory.

Thanks for the response.


Osay Osman Yuuni MEMBERS 19 April 2013 - 08:09 AM
Comment actions Permalink
Avatar
Administrator
Avatar

Hi Oasy,

Did you mean 2.0.0 ? (2.0.1 is not a valid CPBM version).

Could you provide more info on the issues you are facing to enable us to help with the issues?

Thanks and Regards,
Madan


Madan Ganesh Velayudham CITRIX EMPLOYEES 19 April 2013 - 08:37 AM
Comment actions Permalink
Avatar
Administrator
Avatar

Hi Madang. You're right. I meant 2.0.0. Only problem so far is uploading logo. The image is a .png and not big but it fails. Even the favicon also fails. Will check the logs later.

Thanks.


Osay Osman Yuuni MEMBERS 19 April 2013 - 08:58 AM
Comment actions Permalink
Avatar
Administrator
Avatar

Hi Osay/Shanker,

For 1.4.6:

Try ping your hostname. If it's not happening then try adding the entry to /etc/hosts file.

If pinging to the host works, there is a possibility that tomcat is not installed properly.

You may want to re-install:

The following command will remove tomcat and cloud-portal:
rpm -aq | grep tomcat | xargs rpm -e --nodeps --allmatches
rpm -aq | grep cloud-portal | xargs rpm -e --nodeps --allmatches


Rajkumar TM CITRIX EMPLOYEES 19 April 2013 - 09:42 AM
Comment actions Permalink
Avatar
Administrator
Avatar

Hi,

I was able to get CloudPortal 1.4.6 to start up correctly with the following changes:

### /etc/rc.d/init.d/tomcat6
# Get instance specific config file
if [ -r "/etc/sysconfig/${NAME}" ]; then
. /etc/sysconfig/${NAME}
#export TOMCAT_CFG=/etc/sysconfig/${NAME} # <--- Comment this line
fi

### /usr/sbin/dtomcat6
### Uncomment the below section.
## Get the tomcat config (use this for environment specific settings)
if [ -z "${TOMCAT_CFG}" ]; then
TOMCAT_CFG="/etc/tomcat6/tomcat6.conf"
fi

if [ -r "$TOMCAT_CFG" ]; then
. $TOMCAT_CFG
fi

These changes were made based on the 1.4.5 version of the script(s).

Please advise if these changes are correct. Perhaps the real problem is elsewhere.

Thanks.


Shanker Balan MEMBERS 19 April 2013 - 19:12 PM
Comment actions Permalink
Avatar
Administrator
Avatar

Ugh, sorry for the badly formatted previous post.


Shanker Balan MEMBERS 19 April 2013 - 19:25 PM
Comment actions Permalink

Top Contributors