CloudPlatform 4.x

 
 
Gert Jensen
add additional Physical network

Hello,

I have installed some new NICS in our hosts.

Now, i want to see them inside cloudstack, i know i can not add them using th UI, but do
anybody know the curl command i need to know.

I you have one og two examples that would be great... :)

Kind regards
Gert


1 0
Erik Godin
Multiple IPs per VM / Upgrading from 3.0.6 to 4.X

Has anyone had to upgrade from 3.0.6 where they had multiple IPs assigned per VM (i.e.: CloudPlatform assigned the initial IP and then you manually assigned additional IPs within the VM?) Did you leave the additional IPs assigned to the VMs during the uprade, and were they still reachable after the upgrade was completed? Essentially I'm in a situation where it would be very difficult for me to un-assign IPs which were manually added to the VM and I'm trying to see what kind of impact there might be if I leave those IPs as is and proceed with the upgrade.


6 0
Administrator
Upgrade Failure - 3.0.6 - 4.2
Avatar

Upgrade Failure - 3.0.6 - 4.2

I am trying to upgrade a 3.0.6 Patch F install to 4.2 but it keeps failing with the following

Updating the CloudPlatform and its dependencies...
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirrors.coreix.net
* epel: mirrors.coreix.net
* extras: mirrors.vooservers.com
* updates: mirrors.coreix.net
base | 3.7 kB 00:00
cloud-temp | 1.3 kB 00:00 ...
epel | 3.6 kB 00:00
extras | 3.4 kB 00:00
updates | 3.4 kB 00:00
Setting up Update Process
Package(s) cloudstack-* available, but not installed.
No Packages marked for Update
Done


geoff higginbottom MEMBERS 06 November 2013 - 14:47 PM
1 0
Administrator
Invitation time stamps on email show Jan 16, 1970
Avatar

Invitation time stamps on email show Jan 16, 1970

Is there any way to correct that?

Running 4.2.0 on CentOS 6.4

###Sample

Sent: Friday, January 16, 1970 9:15 AM
To: Gordon
Subject: You are invited to join the cloud stack project id=3

You've been invited to join the CloudStack project id=3. Please use token 4U4OL19T6O to complete registration

###

Thanks,
Gordy

Edited by: gstrona360 on Nov 5, 2013 10:38 AM

Edited by: gstrona360 on Nov 5, 2013 10:38 AM


Gordon Stronach MEMBERS 05 November 2013 - 16:37 PM
2 0
Administrator
Can't register a vhd based template
Avatar

Can't register a vhd based template

I try to add a VHD file as a template. But it didn't work as expected. After I add the URL to the VHD file the entry disapears and no usable template was created. I know that the VHD file is 18 GB in size and need some time to copy. On the XenCenter I see high network and disk usage, but the template isn't available after 24 hours.

Any hints for me?

Thomas


Thomas Krampe MEMBERS 31 October 2013 - 07:23 AM
2 0
Administrator
Unable to delete a Zone because there are VMware datacenters associated with this zone.
Avatar

Unable to delete a Zone because there are VMware datacenters associated with this zone.

Hi,

I'm unable to delete a zone cause there are vmware datacenters associated with it but I can't find where to remove them, in fact, I can't see where is the association since i remove everything from the zone already. Is there a way to remove the datacenter from the zone using the UI? or do I have to use some other procedure?

Thanks a lot for your response,


Leonar Castañeda MEMBERS 29 October 2013 - 17:42 PM
1 0
Administrator
Transition from ACS to CCP at same version possible?
Avatar

Transition from ACS to CCP at same version possible?

Hello, Is it possible to transition from a 4.2 ACS install to a CCP installation at the same version? Is there a documented procedure if so? Thanks!

tim


Tim Edwards MEMBERS 29 October 2013 - 17:34 PM
0 0
Gert Jensen
CloudInstanceManager

Hello,

anybody know if there is a new CloudInstanceManager.msi and where i can download this.
The url in the manual does not work... :)

Thank you

Kind regards
Gert


3 0
Administrator
How to install ocfs2 on CentOS 6.3
Avatar

How to install ocfs2 on CentOS 6.3

Hi all,
Now, I can not run ocfs2 on CentOS 6.3. I installed successfully .rpm packages (ocfs2-tools-1.6.3-2.el6.x86_64.rpm, ocfs2-kmod-1.5.0-1.el6.x86_64.rpm), which is contained in CloudStack-PATCH_F-3.0.6-8-rhel6.3.tar.gz packages. But when I start o2cb service it have problems:
[root@centos-6-3]# /etc/init.d/o2cb start
Loading filesystem "configfs": OK
Mounting configfs filesystem at /sys/kernel/config: OK
Loading filesystem "ocfs2_dlmfs": Unable to load filesystem "ocfs2_dlmfs"
Failed

Please help me

thanks.


le duan MEMBERS 20 October 2013 - 03:57 AM
1 0
Administrator
Can not download CloudPlatform-4.2
Avatar

Can not download CloudPlatform-4.2

Hi all,
Please let me know how to can download CloudPlatform-4.2 trial verion? I have tried download from citrix website with my account but not success. Please help me. Thanks.


le duan MEMBERS 19 October 2013 - 17:36 PM
1 0
Administrator
creating host steals ip address and domains
Avatar

creating host steals ip address and domains

Runnnig an 8 core with 32 gig ram, WHM/cPanel bare metal server.

When setting up the cloudstack "host", i accidently used the main ip domain name of the server which moved all my ip addresses from eth0 to cloudbr0 instead of leaving them on eth0 where they belong.

SOLVED, CLOSE/DELETE

Edited by: citrix-apex on Oct 15, 2013 1:19 PM


jay byrd MEMBERS 15 October 2013 - 15:25 PM
1 0
Gert Jensen
Unable to create instances

Hello,

After the upgrade i am having trouble creating instances.
I am getting.
Failed to increment resource count of type primary_storage for account id.

when i tail -f management-server.log i get
2013-10-13 11:08:42,084 DEBUG [xen.resource.CitrixResourceBase] (DirectAgent-56:null) Vm cpu utilization 7.735
2013-10-13 11:08:42,103 WARN [xen.resource.CitrixResourceBase] (DirectAgent-56:null) Error while collecting disk stats from :
You gave an invalid object reference. The object may have recently been deleted. The class parameter gives the type of reference given, and the handle parameter echoes the bad value given.
at com.xensource.xenapi.Types.checkResponse(Types.java:209)
at com.xensource.xenapi.Connection.dispatch(Connection.java:368)
at com.cloud.hypervisor.xen.resource.XenServerConnectionPool$XenServerConnection.dispatch(XenServerConnectionPool.java:909)
at com.xensource.xenapi.VBDMetrics.getIoReadKbs(VBDMetrics.java:210)
at com.cloud.hypervisor.xen.resource.CitrixResourceBase.getVmStats(CitrixResourceBase.java:2731)
at com.cloud.hypervisor.xen.resource.CitrixResourceBase.execute(CitrixResourceBase.java:2631)
at com.cloud.hypervisor.xen.resource.CitrixResourceBase.executeRequest(CitrixResourceBase.java:493)
at com.cloud.hypervisor.xen.resource.XenServer56Resource.executeRequest(XenServer56Resource.java:59)
at com.cloud.hypervisor.xen.resource.XenServer610Resource.executeRequest(XenServer610Resource.java:106)
at com.cloud.agent.manager.DirectAgentAttache$Task.run(DirectAgentAttache.java:186)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
at java.util.concurrent.FutureTask.run(FutureTask.java:166)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:165)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:679)
2013-10-13 11:08:42,106 DEBUG [agent.manager.DirectAgentAttache] (DirectAgent-56:null) Seq 2-1599930409: Response Received:

?
I think i says that there is missing a disk of some sort.. ?

I am not too sure about my secondary storage, how can i check that cloudstack can see this..

anybody ?

Kind regards
Gert

Edited by: Gert Jensen on 13-10-2013 11:10


6 0
Gert Jensen
Upgrade from 3.0.7 -> 4.2 where is xentools

Hello..

I have Upgraded from CloudPlatform 3.0.7 to 4.2, the system is running,
and i can not see any errors..

BUT

All routers and system vms are missing xstools, is this by design ?
as i can not move them from one server to another with our rebooting them ...

Have i done somthing wrong.. ?
I did upload the template before the upgrade, as stated in the manual, i only have xenserver.

I have run the last command:
nohup cloudstack-sysvmadm -d 192.168.1.5 -u cloud -p password -a > sysvm.log 2>&1 &
changeing the ip and password so it fits my install.

and i have no idea of hos the check if the routers are upgraded using this command:
# ssh -i /var/cloudstack/management/.ssh/id_rsa <private-ip> -p 3922
# cat /etc/cloudstack-release

as i can not see privete-ip.. :)

I am using xenserver 6.2 with an upgraded install, not fresh.

Kind regards
Gert

Edited by: Gert Jensen on 12-10-2013 12:09


1 0
Administrator
Unable to Login in UI on CCP-4.2 Trial version
Avatar

Unable to Login in UI on CCP-4.2 Trial version

Hi All,

I have installed Citrix Cloudplatform - 4.2 Trial version on CentOS 6.3.
The installation went successful but i cannot able to login in UI,

Username: admin
Password: password

When i click the "Login" button, it shows this error,

Invalid username or password

After some workaround also i cannot able to fix this issue, even i tried reinstalling the OS(CentOS 6.3) as well CCP-4.2. But it didn't work, same error.

Log Entries:

/var/log/cloudstack/management/management-server.log

root@server CloudPlatform-4.2.0-2-rhel6.4# tail -f /var/log/cloudstack/management/management-server.log
2013-10-05 08:59:44,546 DEBUG [server.auth.MD5UserAuthenticator] (catalina-exec-17:null) Retrieving user: admin
2013-10-05 08:59:44,560 DEBUG [server.auth.MD5UserAuthenticator] (catalina-exec-17:null) Password does not match
2013-10-05 08:59:44,568 DEBUG [server.auth.LDAPUserAuthenticator] (catalina-exec-17:null) Retrieving user: admin
2013-10-05 08:59:44,597 DEBUG [server.auth.LDAPUserAuthenticator] (catalina-exec-17:null) LDAP authenticator is not configured.
2013-10-05 08:59:44,597 DEBUG [server.auth.PlainTextUserAuthenticator] (catalina-exec-17:null) Retrieving user: admin
2013-10-05 08:59:44,604 DEBUG [server.auth.PlainTextUserAuthenticator] (catalina-exec-17:null) Password does not match
2013-10-05 08:59:44,605 DEBUG [cloud.user.AccountManagerImpl] (catalina-exec-17:null) Unable to authenticate user with username admin in domain 1
2013-10-05 08:59:44,620 INFO [cloud.user.AccountManagerImpl] (catalina-exec-17:null) User admin is disabled/locked
2013-10-05 08:59:44,626 DEBUG [cloud.user.AccountManagerImpl] (catalina-exec-17:null) User: admin in domain 1 has failed to log in
2013-10-05 08:59:44,643 DEBUG [cloud.api.ApiServlet] (catalina-exec-17:null) ===END=== 64.103.232.147 -- POST
2013-10-05 09:00:28,313 DEBUG [cloud.api.ApiServlet] (catalina-exec-21:null) ===START=== 64.103.232.147 -- POST
2013-10-05 09:00:28,321 DEBUG [cloud.user.AccountManagerImpl] (catalina-exec-21:null) Attempting to log in user: admin in domain 1
2013-10-05 09:00:28,322 DEBUG [server.auth.SHA256SaltedUserAuthenticator] (catalina-exec-21:null) Retrieving user: admin
2013-10-05 09:00:28,329 WARN [server.auth.SHA256SaltedUserAuthenticator] (catalina-exec-21:null) The stored password for admin isn't in the right format for this authenticator
2013-10-05 09:00:28,335 DEBUG [server.auth.MD5UserAuthenticator] (catalina-exec-21:null) Retrieving user: admin
2013-10-05 09:00:28,339 DEBUG [server.auth.MD5UserAuthenticator] (catalina-exec-21:null) Password does not match
2013-10-05 09:00:28,340 DEBUG [server.auth.LDAPUserAuthenticator] (catalina-exec-21:null) Retrieving user: admin
2013-10-05 09:00:28,349 DEBUG [server.auth.LDAPUserAuthenticator] (catalina-exec-21:null) LDAP authenticator is not configured.
2013-10-05 09:00:28,349 DEBUG [server.auth.PlainTextUserAuthenticator] (catalina-exec-21:null) Retrieving user: admin
2013-10-05 09:00:28,353 DEBUG [server.auth.PlainTextUserAuthenticator] (catalina-exec-21:null) Password does not match
2013-10-05 09:00:28,354 DEBUG [cloud.user.AccountManagerImpl] (catalina-exec-21:null) Unable to authenticate user with username admin in domain 1
2013-10-05 09:00:28,362 INFO [cloud.user.AccountManagerImpl] (catalina-exec-21:null) User admin is disabled/locked
2013-10-05 09:00:28,363 DEBUG [cloud.user.AccountManagerImpl] (catalina-exec-21:null) User: admin in domain 1 has failed to log in
2013-10-05 09:00:28,369 DEBUG [cloud.api.ApiServlet] (catalina-exec-21:null) ===END=== 64.103.232.147 -- POST

Can anyone help me to fix this issue?

Regards,
Karthikeyan


karthikeyan k MEMBERS 04 October 2013 - 22:27 PM
3 0
Administrator
Compute Service offering visibilty
Avatar

Compute Service offering visibilty

Hi

In 4.2 there is an option to specify that compute service offering that is created can be associated to a specific domain. This can be done by removing the public checkbox and then select the domain that the service offering should be associated with. It seems that this setting does not have impact because all compute service offerings are visible in all domains when creating an instance?


Mika Övermark MEMBERS 03 October 2013 - 20:43 PM
2 0

Top Contributors