CloudPlatform 3.x

 
 
Administrator
how to find VM by IP address
Avatar

how to find VM by IP address

Hi,

 

There is a column of search under instance, we can only find the VM with given name but not with ip address.

 

I want to find the VM with ip address, when i add ip address in search column it does not display the vm on which that ip is assigned,

 

Any chances in cloudstack where we can search the VM by enterring ip address ?

 

cloudstack.png


Ameet Nathani MEMBERS 02 March 2015 - 07:32 AM
1 0
Erik Godin
Upgrade console proxy SSL certitficate

I'm reading:

 

 

 

http://support.citrix.com/article/CTX136431

 

 

 

The instructions for "upload custom certificate" stat" give the following as the command to be used:

 

 

 

http://<IPAddress>:<Port>/client/api?command=uploadCustomCerti ficate&id=<ID>&sessionkey=<SESSION_KEY>&name=<NAME>&domai nsuffix=<DOMAIN_SUFFIX>&certificate<URL_ENCODED_CERTIFICATE>.

 

 

 

 

 

When I refer to the API guide I don't see anything for sessionkey, does anyone know what this value should be?  I'm referring to the 3.0.6 API documentation as that's what's linked to on the CCP 3.0.7 documentation page.  http://support.citrix.com/article/CTX136928

 

 

 

 


2 0
Erik Godin
License Server

Does anyone know how one would go at converting a .XVA (license server) to a .VHD so it can be imported in CloudPlatform?


4 0
Erik Godin
Notes on upgrading from 3.0.6 to 3.0.7 PatchF

Here are my notes on the upgrade procedure:

 

 

 

Step 11a:  Before restarting cloud-management, make sure to chown cloud:cloud /var/lib/cloud as per "Known Issues 3.2"

Step 11b:  Step instructs to "wait for the database upgrade to be completed" however doesn't give any instructions on how to confirm this.  To confirm the database upgrade is completed, you should look for the following lines in your management-server.log file:

 

 

INFO  [cloud.upgrade.DatabaseUpgradeChecker] (main:null) DB version = XXXX Code Version = XXXXXXX
 

INFO  [cloud.upgrade.DatabaseUpgradeChecker] (main:null) DB version and code version matches so no upgrade needed.

 

Of course, the expectation is "DB version" and "Code version" should match the version you've upgraded to.

 

 

Step 16: Use 'nohup cloud-sysvmadm -d 192.168.1.5 -u cloud -p password -a > sysvm.log &'.  (replace 'cloud' and 'password' with appropriate username and password)

 

 

In my case, step16 failed to restart one of the routers as well as one of the sysvms.  Keep an eye on the log.  If it reports failing to restart one of the VMs, stop and start manually.


2 0
Administrator
How to Ensure that the database upgrade is complete.
Avatar

How to Ensure that the database upgrade is complete.

Hi,

I am in middle of upgrade process of CloudPlatform 3.0.6 > CloudPlatform 3.0.7.

One of the steps in Installation guide says:

 

"Wait until the databases are upgraded. Ensure that the database upgrade is complete. After
confirmation, start the other Management Servers one at a time by running the same command on
each node."

 

How can I verify that databases are upgraded ?

 

Thank you

T.


tcrgar52 MEMBERS 23 July 2014 - 07:11 AM
3 0
Administrator
site-to-site VPN with YAMAHA RTX1200
Avatar

site-to-site VPN with YAMAHA RTX1200

I have a problem getting VPN connection under the following conditions,

  1. CloudPlatform 3.0.7
  2. YAMAHA RTX1200
  3. Site to Site VPN

Does someone have any result with those combinations?

 


Mitsuhide Takahira MEMBERS 13 December 2013 - 08:41 AM
1 0
Administrator
Console proxy: no listener on port 443
Avatar

Console proxy: no listener on port 443

Hi All.

 

I have just deployed CloudPlatform 3.0.6 (on XenServer 6.1) - it's working well but I'm not able to connect to guest VM consoles when I click on "view console" via the GUI.  It gives me:

 

    Firefox can't establish a connection to the server at 172-26-16-184.realhostip.com.

 

I have followed the debugging steps here: https://cwiki.apache.org/confluence/display/CLOUDSTACK/View+Console+and+Console+Proxy+Troubleshooting

 

When I run through these checks, com.cloud.agent.AgentShell is running and listening on port 8250, but there is no listener on port 443:

 

root@v-13-VM:/var/log/cloud# ps aux | grep -v grep | grep com.cloud.agent.AgentShell
root      6152  0.0  2.4 953420 25524 pts/0    Sl   00:55   0:01 java -Djavax.net.ssl.trustStore=./certs/realhostip.keystore -mx805m -cp ./:./conf:cloud-agent.jar:cloud-api.jar:cloud-axis.jar:cloud-cglib.jar:cloud-commons-codec-1.5.jar:cloud-commons-collections-3.2.1.jar:cloud-commons-discovery.jar:cloud-commons-httpclient-3.1.jar:cloud-commons-logging-1.1.1.jar:cloud-commons-pool-1.5.6.jar:cloud-console-proxy.jar:cloud-core.jar:cloud-google-gson-1.7.1.jar:cloud-log4j.jar:cloud-utils.jar:cloud-vmware-base.jar:cloud-ws-commons-util-1.0.2.jar:cloud-wsdl4j.jar:cloud-xmlrpc-client-3.1.3.jar:cloud-xmlrpc-common-3.1.3.jar:vmware-apputils.jar:vmware-lib-jaxrpc.jar:vmware-vim25.jar:vmware-vim.jar com.cloud.agent.AgentShell root=LABEL console=tty0 xencons=ttyS0,115200 console=hvc0 console=hvc0 template=domP type=consoleproxy host=172.26.16.202 port=8250 name=v-13-VM premium=true zone=1 pod=1 guid=Proxy.13 proxy_vm=13 disable_rp_filter=true eth2ip=172.26.16.184 eth2mask=255.255.255.192 gateway=172.26.16.129 eth0ip=169.254.2.143 eth0mask=255.255.0.0 eth1ip=172.26.16.245 eth1mask=255.255.255.192 mgmtcidr=172.26.16.192/26 localgw=172.26.16.193 internaldns1=128.250.66.5 internaldns2=128.250.201.5 dns1=128.250.66.5 dns2=128.250.201.5

 

root@v-13-VM:/var/log/cloud# netstat -na | grep 8250
tcp        0      0 172.26.16.245:39476     172.26.16.202:8250      ESTABLISHED

 

root@v-13-VM:/var/log/cloud# netstat -na | grep 443
root@v-13-VM:/var/log/cloud#

 

 

Does anyone have any suggestions about what the problem might be here?

 

(I've tried restarting the console proxy VM several times now but to no avail).

 

Regards,

 

Robert.


Robert Sturrock MEMBERS 27 November 2013 - 01:28 AM
3 0
Administrator
Upgrade CCP 3.0.6 to 4.2
Avatar

Upgrade CCP 3.0.6 to 4.2

I am running Xenserver 6.1 - CCP 3.0.6 - CPBM 1.4.6, I am willing to upgrade to newer versions as:

Xenserver 6.2
CCP 4.2
CPBM 2.1

what is the best to do so, is it with one shot? or to upgrade portal then platform then xenserver?
if the second, so can I run CPBM (2.1) on CCP 3.0.6 and Xenserver 6.1 for a while before completing the upgrade?

Your advice and recommendation is appreciated.

Tamer

Edited by: tamer@encloud-me.com on Oct 28, 2013 9:56 AM


Tamer Al-Kabani MEMBERS 28 October 2013 - 05:39 AM
2 0
Erik Godin
Creating VM on desired cluster

Does anyone know how I could force a VM to be created on a specific cluster when two clusters are being managed by CloudPlatform? This is for a one-time purpose.


2 0
Kristoffer Sheather
Citrix CloudPlatform 3.0.7 Patch C Release Date

Citrix,

Please provide a status update on Citrix CloudPlatform 3.0.7 Patch C.

I believe this was supposed to be released in late September / early October and we are clearly well past that timeframe now.

Regards, Kris.


2 0
Administrator
Failed to deploy VM's
Avatar

Failed to deploy VM's

Dear All,
I have two host in a cluster, the hosts are VM's.
Using webserver i have uploaded many .ISO's. When i am trying to create an Instance using this ISO's it is giving the error "Failed to deploy Vm with Id:xx".
But when i am trying to create the Instance through the default template (CentOS), there is no problem at all.

Below is the log when the the deployment is failed.

http://pastebin.com/p021zBUc
Thanks in advance


ISMAIL SHAREEF MOHAMMED MEMBERS 02 October 2013 - 16:40 PM
9 0
Erik Godin
Shutdown all VMs for a particular domain?

Does anyone have any suggestions about how I would go and shutdown all VMs for a particular domain? This domain has a few hundred VMs so this isn't something to be done manually. TIA.


2 0
Erik Godin
Unable to join new server to pool: SR_BACKEND_FAILURE_73: NFS mount error: mount failed with return code 32

*SOLUTION*: Ok so I found the problem. Below is my original post and the symptoms as I saw them at the time. The solution was to add the host in CPP's UI and the host was suddenly able to connect to the storage. To me it seems to make more sense to get all your networking/SRs in order before adding to the cluster but no more than 2 seconds after the host was added the shared SRs were all healthy again (i.e.: all hosts are connected to them) so there's no doubt i my mind this is what made the difference.

Edit: FYI, This is a XenServer which is part of a CloudPlatform Cluster
Edit2: Same issue as http://forums.citrix.com/thread.jspa?threadID=266876&tstart=0 which went unanswered

I've joined a new slave to an existing pool of XenServers but unable to get it to connect to the Primary storage. Here's what I did:

1. Fresh install of XenServer
2. Join to the XenServer pool
3. Verify the management interfaces, make sure they match (in my case, I needed to define the storage network as well as add DNS server for the Primary interface)

Once I was done the above and I've verified that my network settings are correct, I attempted to repair the broken connection to the SR however it fails with "Internal error: Failure("Storage_Access failed with: SR_BACKEND_FAILURE_73: NFS mount error opterr=mount failed with return code 32

I've confirmed I can mount the NFS export from the XenServer without any problems but when I tell XenCenter to repair the SR it fails. Any hints/tips/tricks/direction would be much appreciated.


1 0
Administrator
Help in building cloud
Avatar

Help in building cloud

Hi,
I am new to citrix cloud platform,Using this platform I want to build a private cloud of mu own for the project purpose.
But I am not getting from where to start reading and implementing. Can anyone help me for creating private cloud using xen server? Do I need any other tools/soft to create private cloud using xen server.?If possible please provide any web link which I can refer.
Thank you.


Chinmay Jaiswal MEMBERS 22 September 2013 - 16:30 PM
8 0
Administrator
cluster cannot add host
Avatar

cluster cannot add host

In My CCP environment,i can add a host in a cluster,but add the another host,,the error is "unable to add host" shown..i check the error messages in management-server.log , i can find the error

2013-09-17 16:42:09,928 INFO http://cloud.resource.ResourceManagerImpl (catalina-exec-11:null)
Trying to add a new host at http://192.168.9.25 in data center 1
2013-09-17 16:42:09,989 DEBUG http://xen.resource.XenServerConnectionPool (catalina-exec-11:nul
l) Slave logon to 192.168.9.25
2013-09-17 16:42:10,003 DEBUG http://xen.resource.XenServerConnectionPool (catalina-exec-11:nul
l) Logging on as the master to 192.168.9.25
2013-09-17 16:42:10,613 WARN http://xen.resource.XenServerConnectionPool (catalina-exec-11:nul
l) Catch com.xensource.xenapi.Types$JoiningHostCannotContainSharedSrs Unable to allow host
192.168.9.25 to join pool 192.168.9.24 due to The host joining the pool cannot contain an
y shared storage.
The host joining the pool cannot contain any shared storage.
at com.xensource.xenapi.Types.checkResponse(Types.java:1000)
at com.xensource.xenapi.Connection.dispatch(Connection.java:372)
at com.xensource.xenapi.Pool.join(Pool.java:1058)
at com.cloud.hypervisor.xen.resource.XenServerConnectionPool.join(XenServerConnect
ionPool.java:782)
at com.cloud.hypervisor.xen.resource.XenServerConnectionPool.joinPool(XenServerCon
nectionPool.java:155)
at com.cloud.hypervisor.xen.discoverer.XcpServerDiscoverer.addHostsToPool(XcpServe
rDiscoverer.java:399)
at com.cloud.hypervisor.xen.discoverer.XcpServerDiscoverer.find(XcpServerDiscovere
r.java:204)
at com.cloud.resource.ResourceManagerImpl.discoverHostsFull(ResourceManagerImpl.ja
va:774)
at com.cloud.resource.ResourceManagerImpl.discoverHosts(ResourceManagerImpl.java:6
32)
at com.cloud.api.commands.AddHostCmd.execute(AddHostCmd.java:136)
at com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:263)
at com.cloud.api.ApiServer.queueCommand(ApiServer.java:545)
at com.cloud.api.ApiServer.handleRequest(ApiServer.java:429)
at com.cloud.api.ApiServlet.processRequest(ApiServlet.java:307)
at com.cloud.api.ApiServlet.doPost(ApiServlet.java:68)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

But I login to the 192.168.9.25 and manually mount the primary strage,it's fine.......
How can i solve the problem?


robin dun MEMBERS 17 September 2013 - 08:51 AM
5 0
Erik Godin
Performing actions in CloudPlatform vs XenCenter/XE CLI

I haven't seen this subject addressed before however think it's an important one. What kind of actions shouldn't be done in XenCenter/using XE cli and only done through CloudPlatform's API/GUI on a pool of XenServers (XenServer 6.0.2/CloudPlatform 3.0.6)? More specifically:

- Can I put a host in maintenance mode in CloudPlatform and then manually create a virtual instance on it for testing purposes (after which of course the virtual instance would be deleted before the host is brought out of maintenance). Two new nodes I recently provisioned into the pool are having networking problems so I'd like to provision test VMs while they're in maintenance but at the same time prevent Cloudplatform from provisioning any new VMs on those hosts.

If I were to move around VMs through XenCenter instead of doing it through CloudPlatform's GUI , would that cause a problem? Would CloudPlatform throw some kind of error/alert about the virtual instance not being on the same host it thought it was? I'm wondering if I can enable Dynamic workload Balancing on a XenServer pool managed by CloudPlatform.

TIA.

Erik


4 0
Administrator
Linux VM lose network comms
Avatar

Linux VM lose network comms

HI,
Occasionally we have some customer VMs which lose their network connectivity. The NIC still has the IP configured but it is unable to communicate with anything. It can't ping the gateway (virtual router)

A reboot of the VM is required to fix the problem. Wondering if anyone else has seen this problem?
We are running CloudPlatform 3.0.7 patch B with XenServer 6.1


Luca Salvatore MEMBERS 11 September 2013 - 03:59 AM
1 0
Administrator
deployVirtualMachine API call error - Ambiguous Service Offering
Avatar

deployVirtualMachine API call error - Ambiguous Service Offering

I'm trying to program the deployment of VMs and am running into an issue with certain service offering / template combinations.

I'm specifying serviceofferingid, templateid and zoneid, since these are mandatory parameters to the deployVirtualMachine call, and I'm also specifying networkids since I have more than one isolated network and not doing so throws a different error.

Some combinations of serviceofferingid and templateid work OK, but some throw up an error:

{"deployvirtualmachineresponse":{"errorcode":499,"errortext":"Ambiguous Service Offering, found more than one product bundles that match SO: <id> and template: <id>"}}

I assume therefore that there is another optional parameter I need to specify for these combinations, but am at a loss to work out what it could be.

I've tried "over-specifying" the deployVirtualMachine call by specifying the hypervisor even though I think that's implied in the SO/template combination, but that throws the same error.

Any idea which other parameters might be at fault, or if there's something else wrong?

(If it makes any difference, I'm driving the API from Python using https://github.com/jasonhancock/cloudstack-python-client

using a call like:

cs.deployVirtualMachine({'serviceofferingid': SO_MEDIUM,
'templateid': T_ID,
'zoneid': Z_ID,
'networkids': N_ID,
'hypervisor': 'XenServer',
'ipaddress':'10.20.30.99',
'name':'server001'})

where SO_MEDIUM, T_ID, Z_ID and N_ID are Template, network and zone IDs determined from earlier listServiceOfferings, listTemplates, listZones and listNetworks calls)


mark oakden MEMBERS 06 September 2013 - 09:02 AM
5 0
Gert Jensen
xenserver iptables

Hello,

I am only using advanced networking with vlans.

My problem is when iptables are enabled on the xenserver nothing works..

So i have disabled iptables witk chkconfig iptables off
that does not keep it disabled.

so one a day i go and stop the service service stop iptabes.

But does anybody have a clue to what i should do to keep it disabled.
or open the correct ports on my xenserver /firewall.
My iptables is :
# Firewall configuration written by system-config-securitylevel
# Manual customization of this file is not recommended.
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
:RH-Firewall-1-INPUT - [0:0]
-A INPUT -j RH-Firewall-1-INPUT
-A FORWARD -j RH-Firewall-1-INPUT
-A RH-Firewall-1-INPUT -i lo -j ACCEPT
-A RH-Firewall-1-INPUT -p icmp --icmp-type any -j ACCEPT
-A RH-Firewall-1-INPUT -p 50 -j ACCEPT
-A RH-Firewall-1-INPUT -p 51 -j ACCEPT
-A RH-Firewall-1-INPUT -p udp --dport 5353 -d 224.0.0.251 -j ACCEPT
-A RH-Firewall-1-INPUT -p udp -m udp --dport 631 -j ACCEPT
-A RH-Firewall-1-INPUT -p tcp -m tcp --dport 631 -j ACCEPT
-A RH-Firewall-1-INPUT -p udp -m udp --dport 67 --in-interface xenapi -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m udp -p udp --dport 694 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 443 -j ACCEPT
-A RH-Firewall-1-INPUT -j REJECT --reject-with icmp-host-prohibited
COMMIT

I am no an iptables kind of guy så i you have examples it would help a lot.. :)
My problem is that if if i have 2 servers and thay are on different serveres they can not comunicate.
for instance a server and a router or 2 serveres........

Kind regards
Gert


5 0
Marc Jensen
Help: Castrophic failure of management and database server: DB server unrecoverable

Here is the summary of the issue:
This started with two problems. First there were iscsi connection issues (I know that�s vague, but it seemed that although it said the connection was �ok�, things didn�t work right)
Second, we then lost the master server (xenserver-manager2). The system became unresponsive, so it was rebooted. On restart, it threw a lot of �read-only� errors until it finally stopped responding at all. It failed to find the boot partition on a second reboot.

For manager2, I reinstalled xenserver and then left it alone.

Xenserver manager1 was in its own bad state. It had thought the VMs were running even though it had been rebooted. A second reboot of that one got it back to a normal state with the VMs being offline. I had to force xenserver to say that the VMs that had been running on manager2 were now off. I then removed the �old� manager2 from the pool.

This left us with iscsi connection problems. Xenmanage2 and 3 SRs would not repair. The Xenmanage4 SR seems to have come back healthy.
Using the iscsiadm tool, I can successfully connect to the manage2 and manage3 SRs.
I told xenserver to �forget� manage2 in the hopes I could just re-attach it. As it turns out, you can only add a new one by formatting it in xencenter. To reattach, you must do it from the command prompt. (I was trying to use sr-introduce)

(The following is the short version of the steps that actually worked/gave me forward progress)
Since it was forgotten, of course that doesn�t work. The drive didn�t show up in the pvlist (or vgs) .. Basically it wasn�t listed as any of the known physical/logical volumes.
I managed to recreate it with the same uuid I found by searching through /var/log/SMlog so, it was then listed.
Next I encountered an error that the scsi id was wrong, so following http://support.citrix.com/article/CTX118641 I was able to reintroduce the correct scsi-id to it.
Finally, I�m still stuck the next step. It is missing the Volume Group information. I found a backup of the old one in /etc/lvm/backup/VG_XenStorage-55a045f3-e6fe-71c8-6042-08fa76255b05 (where that string matches the uuid I found in SMlog, and it has the two images we�re looking for on that drive.)
According to http://support.citrix.com/article/CTX116017 we should be able to use that to restore the device. I got as far as step 4, but the command returns with �Please specify a single volume group to restore.�

I have purposely not forgotten manage3, but it cannot reconnect either. I can see it from �Xe sr-list�, but it�s host is listed as �<not in database>�. It is not however listed under �xe pbd-list�
My assumption is that it is having similar issues to manage2

I copied all the logs to /opt/saved_logs just in case the old ones are needed and start to get deleted.

So, I spent two days this week working with XenServer Support to get access to my storage and my management and database virtual machines restored. We got the access to the storage restored to both management servers, but all attempts to recover the database VM were unsuccessful. Once we were able to reconnect to the storage we tried starting the database VM and it failed to start. We determined the problem was the VM header information was corrupted. XenServer support attempted a block-block copy of the VM with no success - same errors and problems. This problem started with the following:

So, does anyone know what are our options here? The cloud pool was unaffected, so all VMs that were in the cloud are still there. Is there any way to re-install the management servers and database and bring the VMs in the cloud pool back under management?

We really would appreciate any help we can get. Thanks.


1 0
Administrator
Unable to view console of VM's through internet
Avatar

Unable to view console of VM's through internet

I want to view my VM's from consoles through internet, but i cannot. I can view them when i am in my office i.e. connected through office LAN (cloud also exits in same network). I have access to the Management server over internet but i cant view the VM's in console.

Error in the console webpage :

The connection has timed out

The server at (IP).realhostip.com is taking too long to respond.

* The site could be temporarily unavailable or too busy. Try again in a few moments.
* If you are unable to load any pages, check your computer's network connection.
* If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the web
Try Again


ISMAIL SHAREEF MOHAMMED MEMBERS 30 August 2013 - 13:02 PM
19 0
Gert Jensen
CloudPlatform 3.0.7B - Windows 2012 template ?

Hello,

Does anybody know what i need to update, så i am able to select that a VM is as Windoiws 2012 Server.

When i choose which OS the computer is i am only able to select Win2008R2 ?

Kind regards
Gert Jensen


5 0
Administrator
Unable to add Instances
Avatar

Unable to add Instances

I am unable to add instances, getting following error,

"Unable to create a deployment for VM[User|i-2-8-VM]"

My Environment Details :
RHEL x64
CloudStack 3.0.0-1
XenServer 6.0

Secondary Storage : NFS Share 10 GB (OpenFiler Server)
Primary Storage : iSCSI 3* 10GB LUN (OpenFiler Server)

Log:
--------
2013-08-25 23:10:38,991 DEBUG [cloud.user.AccountManagerImpl] (catalina-exec-16:null) Access granted to Acct[2-admin] to Domain:1/ by DomainChecker
2013-08-25 23:10:45,982 DEBUG [storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null) Zone 1 is ready to launch secondary storage VM
2013-08-25 23:10:46,139 DEBUG [cloud.consoleproxy.ConsoleProxyManagerImpl] (consoleproxy-1:null) Zone 1 is ready to launch console proxy
2013-08-25 23:10:46,689 DEBUG [network.router.VirtualNetworkApplianceManagerImpl] (RouterStatusMonitor-1:null) Found 0 routers.
2013-08-25 23:10:49,702 DEBUG [cloud.configuration.ConfigurationManagerImpl] (catalina-exec-24:null) Access granted to Acct[2-admin] to zone:1 by DomainChecker
2013-08-25 23:10:49,703 DEBUG [cloud.configuration.ConfigurationManagerImpl] (catalina-exec-24:null) Access granted to Acct[2-admin] to zone:1 by DomainChecker
2013-08-25 23:10:49,719 DEBUG [cloud.vm.UserVmManagerImpl] (catalina-exec-24:null) Allocating in the DB for vm
2013-08-25 23:10:49,719 DEBUG [cloud.vm.VirtualMachineManagerImpl] (catalina-exec-24:null) Allocating entries for VM: VM[User|i-2-8-VM]
2013-08-25 23:10:49,723 DEBUG [cloud.vm.VirtualMachineManagerImpl] (catalina-exec-24:null) Allocating nics for VM[User|i-2-8-VM]
2013-08-25 23:10:49,732 DEBUG [cloud.vm.VirtualMachineManagerImpl] (catalina-exec-24:null) Allocaing disks for VM[User|i-2-8-VM]
2013-08-25 23:10:49,738 DEBUG [cloud.vm.VirtualMachineManagerImpl] (catalina-exec-24:null) Allocation completed for VM: VM[User|i-2-8-VM]
2013-08-25 23:10:49,738 DEBUG [cloud.vm.UserVmManagerImpl] (catalina-exec-24:null) Successfully allocated DB entry for VM[User|i-2-8-VM]
2013-08-25 23:10:49,940 DEBUG [cloud.async.AsyncJobManagerImpl] (catalina-exec-24:null) submit async job-19, details: AsyncJobVO {id:19, userId: 2, accountId: 2, sessionKey: null, instanceType: VirtualMachine, instanceId: 8, cmd: com.cloud.api.commands.DeployVMCmd, cmdOriginator: null, cmdInfo: {"id":"8","response":"json","templateId":"eaf1ae51-649b-4269-99f5-1b89130e5a60","sessionkey":"3bTlCpT9xfqEnfFsLLXwZ9D7Up8\u003d","ctxUserId":"2","hypervisor":"XenServer","serviceOfferingId":"46868cd8-fae6-4f08-97e2-699c5ab10c42","_":"1377461451328","securitygroupids":"48b6faa0-7b6c-4bf3-aed3-20d62a0ef128","ctxAccountId":"2","ctxStartEventId":"203","displayname":"MyVM01","zoneId":"f484c790-e41c-47c7-a8fc-d592d27cb164"}, cmdVersion: 0, callbackType: 0, callbackAddress: null, status: 0, processStatus: 0, resultCode: 0, result: null, initMsid: 8796756729983, completeMsid: null, lastUpdated: null, lastPolled: null, created: null}
2013-08-25 23:10:49,945 DEBUG [cloud.async.AsyncJobManagerImpl] (Job-Executor-5:job-19) Executing com.cloud.api.commands.DeployVMCmd for job-19
2013-08-25 23:10:50,015 DEBUG [cloud.capacity.CapacityManagerImpl] (Job-Executor-5:job-19) VM state transitted from :Stopped to Starting with event: StartRequestedvm's original host id: null new host id: null host id before state transition: null
2013-08-25 23:10:50,015 DEBUG [cloud.vm.VirtualMachineManagerImpl] (Job-Executor-5:job-19) Successfully transitioned to start state for VM[User|i-2-8-VM] reservation id = 9b70e921-6ea1-48f3-8989-3e5e2621ffe3
2013-08-25 23:10:50,090 DEBUG [cloud.vm.VirtualMachineManagerImpl] (Job-Executor-5:job-19) Trying to deploy VM, vm has dcId: 1 and podId: null
2013-08-25 23:10:50,091 DEBUG [cloud.vm.VirtualMachineManagerImpl] (Job-Executor-5:job-19) Deploy avoids pods: null, clusters: null, hosts: null
2013-08-25 23:10:50,092 DEBUG [cloud.deploy.FirstFitPlanner] (Job-Executor-5:job-19) DeploymentPlanner allocation algorithm: random
2013-08-25 23:10:50,092 DEBUG [cloud.deploy.FirstFitPlanner] (Job-Executor-5:job-19) Trying to allocate a host and storage pools from dc:1, pod:null,cluster:null, requested cpu: 1000, requested ram: 1048576000
2013-08-25 23:10:50,092 DEBUG [cloud.deploy.FirstFitPlanner] (Job-Executor-5:job-19) Is ROOT volume READY (pool already allocated)?: No
2013-08-25 23:10:50,092 DEBUG [cloud.deploy.FirstFitPlanner] (Job-Executor-5:job-19) Searching all possible resources under this Zone: 1
2013-08-25 23:10:50,094 DEBUG [cloud.deploy.FirstFitPlanner] (Job-Executor-5:job-19) Listing clusters in order of aggregate capacity, that have (atleast one host with) enough CPU and RAM capacity under this Zone: 1
2013-08-25 23:10:50,095 DEBUG [cloud.deploy.FirstFitPlanner] (Job-Executor-5:job-19) CPUOverprovisioningFactor considered: 1.0
2013-08-25 23:10:50,104 DEBUG [cloud.deploy.FirstFitPlanner] (Job-Executor-5:job-19) Checking resources in Cluster: 1 under Pod: 1
2013-08-25 23:10:50,104 DEBUG [cloud.deploy.FirstFitPlanner] (Job-Executor-5:job-19) Calling HostAllocators to find suitable hosts
2013-08-25 23:10:50,104 DEBUG [allocator.impl.FirstFitAllocator] (Job-Executor-5:job-19 FirstFitRoutingAllocator) Looking for hosts in dc: 1 pod:1 cluster:1
2013-08-25 23:10:50,105 DEBUG [allocator.impl.FirstFitAllocator] (Job-Executor-5:job-19 FirstFitRoutingAllocator) FirstFitAllocator has 1 hosts to check for allocation: [Host[-2-Routing]]
2013-08-25 23:10:50,108 DEBUG [allocator.impl.FirstFitAllocator] (Job-Executor-5:job-19 FirstFitRoutingAllocator) Found 1 hosts for allocation after prioritization: [Host[-2-Routing]]
2013-08-25 23:10:50,108 DEBUG [allocator.impl.FirstFitAllocator] (Job-Executor-5:job-19 FirstFitRoutingAllocator) Looking for speed=1000Mhz, Ram=1000
2013-08-25 23:10:50,109 DEBUG [cloud.capacity.CapacityManagerImpl] (Job-Executor-5:job-19 FirstFitRoutingAllocator) Checking if host: 2 has enough capacity for requested CPU: 1000 and requested RAM: 1048576000 , cpuOverprovisioningFactor: 1.0
2013-08-25 23:10:50,112 DEBUG [cloud.capacity.CapacityManagerImpl] (Job-Executor-5:job-19 FirstFitRoutingAllocator) Hosts's actual total CPU: 23408 and CPU after applying overprovisioning: 23408
2013-08-25 23:10:50,112 DEBUG [cloud.capacity.CapacityManagerImpl] (Job-Executor-5:job-19 FirstFitRoutingAllocator) Free CPU: 22408 , Requested CPU: 1000
2013-08-25 23:10:50,112 DEBUG [cloud.capacity.CapacityManagerImpl] (Job-Executor-5:job-19 FirstFitRoutingAllocator) Free RAM: 6565643200 , Requested RAM: 1048576000
2013-08-25 23:10:50,112 DEBUG [cloud.capacity.CapacityManagerImpl] (Job-Executor-5:job-19 FirstFitRoutingAllocator) Host has enough CPU and RAM available
2013-08-25 23:10:50,112 DEBUG [cloud.capacity.CapacityManagerImpl] (Job-Executor-5:job-19 FirstFitRoutingAllocator) STATS: Can alloc CPU from host: 2, used: 1000, reserved: 0, actual total: 23408, total with overprovisioning: 23408; requested cpu:1000,alloc_from_last_host?:false ,considerReservedCapacity?: true
2013-08-25 23:10:50,112 DEBUG [cloud.capacity.CapacityManagerImpl] (Job-Executor-5:job-19 FirstFitRoutingAllocator) STATS: Can alloc MEM from host: 2, used: 1342177280, reserved: 0, total: 7907820480; requested mem: 1048576000,alloc_from_last_host?:false ,considerReservedCapacity?: true
2013-08-25 23:10:50,112 DEBUG [allocator.impl.FirstFitAllocator] (Job-Executor-5:job-19 FirstFitRoutingAllocator) Found a suitable host, adding to list: 2
2013-08-25 23:10:50,112 DEBUG [allocator.impl.FirstFitAllocator] (Job-Executor-5:job-19 FirstFitRoutingAllocator) Host Allocator returning 1 suitable hosts

--------------------
Continued in reply


ISMAIL SHAREEF MOHAMMED MEMBERS 25 August 2013 - 20:25 PM
3 0
Kurt Bachelder
XenServer hotfixes - apply all or "compatible"?

Hi all -

I'm curious if anyone has found the appropriate methodology for determining which hotfixes to apply to XenServer for Cloud Platform 3.0.6... Looking at the matrix in the article below, it appears that only specific XenServer patches are "compatible":

http://support.citrix.com/article/CTX134803

However, we have heard from other Citrix representatives that the best practice is to apply "all hotfixes" for the version of XenServer we are running, and the Installation Guide seems to echo this in section 7.1 (5th top-level bullet) with:

Be sure all the hotfixes provided by the hypervisor vendor are applied. The Alerts area of the
Dashboard in the CloudPlatform UI will show notifications about new Citrix XenServer software
updates as they become available. Apply patches as soon as possible after they are released. It is
essential that your hosts are completely up to date with the provided hypervisor patches.

What is the correct approach?

Kurt

Edited by: kbachel903 on Aug 21, 2013 10:47 AM


4 0
Administrator
Option to add a physical network post zone creation
Avatar

Option to add a physical network post zone creation

Hello All,

I am looking for an option to add more physical networks post the zone creation process.

Please suggest , is there an option this can be done from the UI.

Regards

Vincent S


Faustina Glory MEMBERS 20 August 2013 - 11:14 AM
3 0
Administrator
VM licensing with KMS Server
Avatar

VM licensing with KMS Server

Hello, I am doing a public cloud, but after VM is lunched then the virtual router could not reach the KMS server in order to activate the windows server!, I am using Citrix cloud platform and portal, so how the cloud platform can communicate with the KMS server after launching the VM?


Tamer Al-Kabani MEMBERS 13 August 2013 - 06:30 AM
9 0
Administrator
Convert different formats to vhd
Avatar

Convert different formats to vhd

Anyone come up with some tool(s) to convert to VHD?
This seems to be of some pain to users...


Patrick Markkula MEMBERS 12 August 2013 - 17:46 PM
1 0
Gert Jensen
the different logfiles what are they for..

Hello,

I came across a problem yesturday i realised that i did not know all the logfiles and what they are for.
can anybody help me, i can guess on some of the log names, but do anybody know the right function of the logs,
or can anybody provide me with a link so i can read about it.?

/var/log/cloud/management
access_log.2013-08-12.txt
api-server.log
awsapi.log
catalina.out
localhost.2013-08-12.log
manager.2013-08-12.log
management-server.log

/var/log/cloud/usage
usage.log

Thank U

Kind regards
Gert


1 0
Administrator
Cloudplatform GPU
Avatar

Cloudplatform GPU

Hi!

Is any plan in Cloudplatform to support GPU passthrough?
Until is GPU not formally supported is it possible asign GPU to one VM via XenCenter?
Coud this have any negative sideeffect to any functionality?

Kind regards,

Janez


Janez Kremzer MEMBERS 09 August 2013 - 07:12 AM
2 0
Administrator
Juniper SRX Integration in Isolated Guest Networks
Avatar

Juniper SRX Integration in Isolated Guest Networks

CCP Version: 3.0.5

I realize that this is an older version and while it might be possible to upgrade, we've completed all the testing for this project using this version...

We are trying to integrate a SRX as the default gateway in an Advanced (Isolated) network. We have the device connected into CCP and if the 'admin' user creates an isolated network, using the appropriate service offering, everything works as expected. Unfortunately, if any other user, even on with the "Admin" role, creates an isolated network, using the same service offering, we only see the following error.

2013-07-29 22:53:17,373 ERROR [cloud.network.ExternalFirewallDeviceManagerImpl] (Network-Scavenger-1:null) External firewall was unable to find the source NAT IP address for account <account name>

I'm not sure if it is relevant, but the users already have other guest networks that use the VR as their default gateway.

Has anyone seen similar behavior? Is this a known issue, even thought I can't find anything about it in the release notes for newer versions?

Any help would be appreciated.

--Mike


Mike Little MEMBERS 06 August 2013 - 23:52 PM
1 0

Top Contributors